Weird Input Bug

Following on from a different post. I created a percussion kit which consist of 6 Gongs:


I then created a percussion map for all 6 Gongs single hits and their respective Rolls:

I then, under Daniel’s recommendation, set the Layout for percussion to 5 lines and set Dorico to accept Percussion Map instead of Staff position.
I then double clicked on the staff and I was able to write all the different gongs directly from my MIDI keyboard (C4=Gong 1, D4=Gong 2,etc.)

So then I exported the Percussion Map and the Percussion Kit. Opened an orchestral score I’m building as a template, imported the percussion Kit, imported the Percussion Map, assigned the instrument to the correct channel, assigned the Map to the channel, changed Layout options to 5 lines:


But when I try to input anything it just inputs the same pitch/Gong i.e. whether I press C4 on the keyboard or A4 Dorico just notates the Gong above the staff (Gong 6). What’s more irritating is that even if I use the arrows to select a different Gong Dorico continues to input the same one. Furthermore, even if I correct them after input i.e. using ALT+up/down arrows, Dorico continues to play the same pitch (Gong 1 which is incorrect anyway since the Gong above the staff should be Gong 6 according to the Percussion Map). Weirdly, if I use the Roll articulation it will jump to the correct group but not the different gongs e.g. C4 is Gong 1 single hit and C5 is Gong 1 Roll, if input any of the Gongs, then adjust them manually and alternate between single hit and roll, Dorico will play C4 (Gong 1) and C5 (Gong 1 Roll) for all of them.
Things I’ve tried/checked:

  • Replicating the procedure on an empty project, I get the same issue


  • Going back to the original file, everything works as expected


  • Double checking that all the settings are the same, problem continues


  • Re exporting the Kit and the Map


  • Rechecked that both the Map and the Kit looks the same on the original project and the imported version, everything looks fine


  • Toggle and apply use Map instead of stave position back and forth

I could attach the files if needed but let me know if you need anything besides the Dorico file e.g. Percussion Maps, Percussion Kit, etc.

Regards,

This thread might help: https://www.steinberg.net/forums/viewtopic.php?f=246&t=139678

Hi Leo! No, that’s not it. The problems describe here have to do with simultaneous input, but they all seem to have the correct instruments being input. In my case Dorico is ignoring the Percussion Map all together…

It was the bit about having input set to use the percussion map vs stave position - have you checked that?

Ah I get ya! Yes, I missed that step in my original post I will add it. And also one of the things I tried was toggling it, applying, trying it again, etc. The problem doesn’t stop… But also Dorico is not playing it right, so that particular setting wouldn’t affect playback.

I suspect there is in fact a bug of some kind here, as I think you’re describing the same issue as in this thread. It would be helpful to have both the original Dorico project in which you have defined the kit and the percussion map where everything works, and another Dorico project into which you’ve imported the kit and the percussion map but where it doesn’t work. If you could also include the .doricolib files that you used to export the percussion map and the percussion kit, that would be very helpful, too. Zip it all up and put it here and I’ll take a look as soon as I get a chance to dig into it.

Yes indeed, it does appear to be the same bug and his/her solution worked i.e. import the flow from the original instead of the maps. I attach the files in any case since this is not the way you intended it to work.
Percussion Bug.zip (694 KB)

Annoyingly, the bug is back today and now it happens with all instruments. Yesterday before going to bed I was inputting all instruments from the MIDI keyboard without any problems (including the imported Gong Set), today none of the one line percussion instruments (Bass drum, Toms, etc.) accept any input from the MIDI keyboard and the Gongs are back to just accepting the one Gong… I assure you I have changed nothing, I was just continuing exactly from where I left off. What was it that I needed to press to input drums, Y?

Yes, using Y to input a note of the default pitch, i.e. at the current staff line or space position of the mini caret on the percussion staff, should always work reliably.

OK thank you, I’ll have to add the shortcut to my streamdeck then… :wink: Hopefully this is something that is getting improved in the new version, seems inconsistent to have to work differently on percussion instruments from everything else.

So today the Gongs are back (working correctly) but single line instruments still refuse input from the midi keyboard. Just thought I’d let you know.

Please see this thread for an update on the issue of MIDI input onto a custom percussion kit imported from a library file that originated in another project.

What incredible support you guys give, seriously! 4 months later and you still remember me and this problem… Wow!

Presumably when you speak of “the next update” it is not 3.0.10, right? It is another one coming in the next months?

Be well!

It’s not 3.0.10, no, because that came out on Tuesday last week, and I posted my reply two days after that, on Thursday.

Got ya! Thank you again!