WEIRD issue. Not sure if it's Cubase or Synthmaster 2 VST

Hi…
I am trying to figure out an issue that I am having with a VST and am trying to make sure first that it isn’t Cubase that is causing the issue first. The VST is Synthmaster 2. The problem that I am suddenly having is that the sound of the preset that I created and saved completely changes from the one that I had created after you select / highlight the track in Cubase. If I open the project and hit play then the preset sounds just like it did when I created, but as soon as I select the track the tone and sound completely change. There’s no way to change the sound back unless you close out the project and open it again. However, if you select the track after opening it then it changes.

Here’s the WEIRD part…I tried to adjust the patch again after the sound changed upon clicking on the track and re-saving it under a new preset name. That got me by while I worked on the project but now when I render out the song the track sounds the way it was supposed to sound when I had originally made the patch.

I am not having any of these issues with any other VSTs which is why I think it’s the VST and not Cubase, but is there anything that could be causing this in Cubase that I maybe accidentally turned on and didn’t realize it?

If that’s your only VST that has this problem, contact the Synthmaster 2 developer.

I thought it was my only VST with the issue, but tonight it is now also happening with Sylenth so this has to be a Cubase issue. I have no idea where to begin to even try diagnosing this. Any ideas what could be causing this? I have confirmed that I am updated to the latest update for my version. I’m running Cubase 9 Pro v9.0.40.

Most likely you have recorded some parameter changes on the midi track, open the list editor and look for anything not related to the playing.

There isn’t anything in the list editor. This is now happening on every project, even projects from months ago where I wasn’t having this issue at all. Now, suddenly it’s an issue on those projects too. It’s the same situation every time. I open a project and hit play. Track plays fine. If at any point during playback I just click on the track name the patch completely changes tone. The patch name and all of the patch settings stay the same despite the sound changing. The only way to get the original sound of the patch back is to close out the project without saving it and re-opening it. This seems to only be happening with VST tracks where I have used either Sylenth or SynthMaster.

Tell me how this makes any sense and for it to happen all of a sudden? I’m so confused. I think this has to be some sort of weird bug with Cubase? Ideas?

So I completely forgot until a few minutes ago that this has happened to me before. About 3 years ago I ran into the same issue. It has something to do with my midi keyboard. However, the trick that worked last time to fix it is no longer working. Here’s a link to that thread. If you have any ideas please let me know.

https://www.steinberg.net/forums/viewtopic.php?f=146&t=87040&p=786800#p786800