Weird lag in cubase

ive loaded up a song i was working on and when im trying to record any midi parts im getting a really weird lag.
ive checked my sound card and its set to 126 but even if i lower it to its lowest setting im still getting the same problem.
my cpu is fine everything looks and sounds fine except the lag.

if i open my midi edit page once ive recorded anything i can see the parts are off by about half a second but when i created the track before everything was fine…

anyone know how to fix this?
im on windows 10…uad apollo twin usb…cubase 12.0.20 (i havent updated cubase to the newest version because i was getting massive problems with 12.0.40)

hope someone can help

So to understand correctly, while playing and recording the part (I guess a VST instrument), everything is fine, but the recorded MIDI events are off the grid where they should be?
Is this just with this project or with every project?
Could you check “Studio Setup->MIDI->MIDI Port Setup” whether “Use System timestamp for Windows MIDI inputs” is disabled? If yes, enable that and try if that helps.

Do you have plugins on the master bus or anywhere else. Probably not the problem as you say the recorded midi is very late and even with high latency Cubase should compensate for the recorded midi.

You can also make sure of the following in Preferences.
Record/MIDI/ASIO Latency Compensation Active by Default - ON

You can also use Constrain Delay Compensation to record performances at tightest latency possible
Arrange window/Bottom left button with a clock that turns orange when active.

This button bypasses the heaviest latency plugs to allow you to record as tight as possible

1 Like

thanks for replys …yes my prefs had gotten changed Record/MIDI/ASIO Latency Compensation Active by Default - ON was switched too off and the orange icon at the bottom was swtched off ,ive enabled them and everythings fine …thanks again :slight_smile:

Constrain Delay Compensation (orange clock) needs only to be on when you are recording live MIDI.

You need it off to hear your mix back with all of the processing you have added.

Enjoy!