Weird percussion problem

I’m having a problem. If you look at the last bar in the galley view, there is a bass drum note. Why does it not appear in the page view? You can see from the setup at the left that bass drum is in perc. 2. But in the page layout there is an empty xylophone staff and no bass drum. ???

Try restarting Dorico; sometimes that forces a screen redraw that solves the problem.

I think we would need to see the project itself to be able to diagnose this problem, Alan. Please consider cutting it down to just the problematic section (e.g. first use Save As to make a copy of your project, use Split Flow a couple of dozen bars before the end, then delete the main part of the flow, and then zip up and attach that bit here, assuming it still demonstrates the problem).

I removed all the wind instruments and split the flow. I found that if I split the flow much later than where I did, the problem goes away! I tried to attach the file here, but it says 'invalid file extension" (the extension is just dorico!). I will email it to you.

This is a limitation of the forum software. If you zip up the dorico file, it will attach to your post just fine. (Actually, all you need to do is rename the file from filename.dorico to, which is enough to fool the forum into attaching it!)

Here it is. (447 KB)

This is now happening in another movement (a separate file) of the same piece. I also tried exporting the percussion parts as xml and reimporting them. Same problem. Tried exporting the flows and reimporting them. Same problem.

I sent the file to Daniel and John Barron a couple of days ago, no news …


Trust that they are looking at your project and the issue, or will be shortly. The team has been very busy, and will get to it when they can. Daniel, and the rest of the team are incredibly good about getting back to people about bugs/issues.


Also, I tried opening your file, and it didn’t appear to be a Dorico file.

It opened up as a bunch of independent files, after it unzipped it. You might want to try to just the extension to .zip and try again.


Thanks for your comment.

Here is the same (Dorico) file, but I just changed the extension to zip. It is not really zipped. Incidentally I sent the original file (unzipped) by email to Daniel and John Barron the first day. (447 KB)

I found one way to reproduce your problem (and for what it is worth, I am unable to open your other file as well, still shows up as a series of independent files).

Was the bass drum at one point a player by themselves? That you later combined into the Xylophone part?

I ask because if you create a Xylophone player, and add several instruments. Then add a separate bass drum player. If you edit the master pages to hide the bass drum player from the frames (or rather disregard them from the frames), then move the bass drum part to the xylophone player, Dorico continues with disregarding the bass drum from the flows.

I am not sure what a fix would be, but I was able to reproduce it from here. I am busy today and won’t have a lot of free time, but maybe this evening when I get home I will have time to play around this. And see if there is a way to undo the hiding.


Thanks for your interest. :slight_smile:

The bass drum was originally in an XML file, where each percussion instrument was separate. I created two percussion players and assigned the various instruments to them. I did nothing at all to the master pages. Btw I have done this in many other files and never had this problem.

Btw, to open the file, do NOT try to unzip. Just change the name so that instead of the zip extension it says .dorico. That will do it. Or perhaps you are on a Mac; I think Macs handle this differently, I don’t know the details.

I have messed around with your file, and this is odd. If you move the bass drum to a separate empty handed player, Dorico shows the bass drum part. When you add the bass drum back to the percussion player (percussion 2, if I recall correctly) it doesn’t display. However, if you place the xylophone in the empty handed player, the bass drum part shows under Percussion 2. So I am thinking the Xylophone might be the culprit.

Very weird… adding a new xylophone part (Xylo 2), and moving Xylo 1 to the empty handed player shows the part as it should be. But once you input music onto Xylo 2 you get the very same problem all over again. What is even more weird… is that when you add a Xylophone under your file, it gives the option of having a 2 staff Xylophone part (grand staff) which is not the norm. Further investigation shows that when I create a new file and add a Xylophone that a 2 staff option doesn’t exist. So I am thinking in the import of the XML file, Dorico is now changing the set up of what a Xylophone is. I believe this might be where your problem occurs. However, try as I might, I am unable to force Dorico to do something different here. It might be best to create a new version of the file, and copy and paste bar by bar. It will be tedious for sure, and I can’t be certain that will work either.

Hopefully someone from the team will get back to you on this when they have a chance.


To save you the time, I tried the copy and paste technique to have it produce nothing. It still does not work.

If you click on the G clef at the start of the Xylo part, you can select the clef and delete it, which means during the XML export, it added a clef that way unnecessary. However, the fact that you can add a 2-staff Xylo still sticks out as odd to me. Maybe there is a hidden 2nd staff that you we don’t see that might have things attached to it, and therefore is preventing Dorico from adding/showing the bass drum part. But as I said in the previous post, I am at a loss here.


Another oddity, is under the layout options… when you select a specific player and look under the ‘players’ category, it shows an empty player attached to all of the parts. In other files I have, this does not seem to be the case.

Another odd thing… if in the layout options you turn off ‘allow instrument changes’, you will see the score populates with all of the other instruments. However, I do not see time signatures, nor rests being displayed.


Robby, just to clarify:
.dorico files are actually zipped folders containing multiple files.
If you zip a .dorico file you get a zipped folder of separate files within a further Zip container.
If you unzip a .dorico file you get a bunch of separate files.

That’s the way I understand it, anyway…


I believe you are correct, and that is my understanding as well. The issue was, clicking on the file automatically unzips the file on macOS. I wasn’t thinking clearly, so every time I clicked on the link macOS kept unzipping it. What I had to do was save the file (not click on it to download), then change the ‘.zip’ to ‘.dorico’. Very stupid mistake on my part. It’s been a few long days for me. I have downloaded and checked out other people’s files before, so for some reason I was doing it wrong yesterday.


Today I heard from John Barron, and he says that in the next (free) update this will be fixed. Phew! :slight_smile: