Weird rendering of mono files

Sometimes I get weird rendering result of mono file = it is not mono but some kind of dual mono file (original channel stays as a left channel, right channel is either empty or shifted in time or just noise).

The usual scenario is this: I open stereo file, convert it to mono (Copy selection to new window -> Convert to mono (Mix)), make some changes (editing, normalizing etc) and now if I try to use any plugin in Master section (incl. UV22HR dithering) I get this weird result (e.g. instead of processing the untitled mono file created from original stereo file, WL creates a new 3rd dual-mono file as a result). The only way out of this situation is to save the mono file, close WL, re-open the file and then apply the plugins.

Am I the only one experiencing this? What could be wrong?

I experienced something similar before last year,
see this thread:

https://www.steinberg.net/forum/viewtopic.php?f=47&t=940

In my case trashing my user preferences did solve this issue,
so you might give it a try.

The preferences are found at this place (here on Win Vista):

C:\Users"Username"\AppData\Roaming\Steinberg\WaveLab 7 (hidden folder by default).

Rename the folder “WaveLab 7” , then start WaveLab again
See, if you still get this issue afterwards.
If this fixes it, of course you have to configure WaveLab again to your liking.

PS: I right now just tried the scenario you described, but it is working for me like expected,
so there’s a good chance, that trashing the user preferences indeed may help.
Hope you get it sorted.

Cheers

I can’t reproduce this problem. Could it be that you render with a “dual mono” setting, in the render dialog? If you can reproduce this issue, watch the output file format you select.

I always used “Process in place” (Whole file) e.g. no way of specifying the output file format.

I don’t believe that trashing my preferences would help as this weird thing happens only occasionally e.g. I can’t easily / quickly reproduce it, however whenever I work on some file(s) for a longer time, eventually it always happens.

If I get into that problem again, what should I do in order to provide some helpful info? As I mentioned before what only helps is to close / open WL and then I can do the intended (identical) procedure which before lead to this weird dual-mono file.

Screenshot (with tab) of what you call the dual mono file, could be useful. And of course, the exact processing you did before.