Weird Spacing Issue

Hello, I’m having an issue with staff spacing.

I’ve set a global spacing which works in the pages before and after this as long as there are notes in the horn parts, but I have a couple page that are mostly blank except for the rhythm section. I’m not even sure where to look for a solution, to be honest. Any ideas?

Edit: Also, I imported this as an .XML file from Finale and, upon further review, this spacing thing is actually happening past this point in the score.

See e.g. this thread.

1 Like

Thank you!

I was able to fix the issue by using the “copy staff spacing” function.

I would recommend using the layout options and vertical spacing in the first instance as much as possible, as “copy staff spacing” works by manually overriding the position of each staff. These staff spacing overrides (indicated by red handles in Engrave mode when Staff Spacing is selected) are tied to the page, so if you later e.g. add a title page at the beginning of the layout, all subsequent staff spacing overrides get lost.

If you can get your vertical spacing settings set as close to what you want in Layout Options as possible, you’ll find the results are more robust.

Thank you for the suggestion. In this instance, I imported the work from a Finale XML file, and I think many of my issues stem from that. The challenge is now figuring out how correct the issues as they pop up.

You could try removing all staff spacing overrides to make sure everything should, at least, be following the layout options for vertical spacing.

I finished the score, condensed it, and had the same spacing issues as before. I then reset the spacing overrides and tried to copy the spacing from a correct page, but nothing happened.

I haven’t checked whether this was covered in the thread Leo linked you too earlier, but if by “spacing issue” you mean that some pages have staves spanning the full height but other pages stop halfway, that’s most likely to do with vertical justification. If there are pages below the justification threshold, and otherwise you’re happy with the staff size/page size etc, try decreasing the justification threshold.

1 Like

Yes! This is what I’ve been looking for. Thank you so much!

Edit: Just for clarification, I adjusted the distances in Vertical Justification Threshold to 40%, and everything fixed itself.