What happened to the Audio Part Editor

I’ve just updated from N4 to N6 and in the past the audio part editor worked with bottom one played and now it’s in take order which negates the whole idea of the part editor. I now have to manually cut and mute takes instead of just dragging with the range tool :frowning: .
I had a long voice over session with many takes and it took me so long to do it my client left and we missed the deadline.

Can we please have an option for it to work the old way of bottom one plays.