What is this mess?

Where is 5th beat, and what explains the rest and high hat groupings as well as the caret representation?

You need to add a beat to the 5/4 bar. Use Shift-B +1q.

Why? I put it in 5/4.

Did you try? This can happen when you change 4/4 to 5.4. Trips me up all the time for similar changes.

Activate Insert mode (press i) before changing Time Signature.
Remember to deactivate again (press i again)


1 Like

It’s probably because the repeat mark is at a fixed beat position.

1 Like

It seems to me that a normal behaviour for the software in this circumstance should be to add a beat to the measure as a response to changing the 4/4 to 5/4, just as it does when no repeat barline is present.

Any kind of non-standard barline is treated internally as a time signature. When adding a time signature, Dorico automatically rebars as far as the next time signature. It won’t move subsequent time signatures unless you turn on Insert mode first.

(See the final paragraph on this page)