What is wrong with my simple Template?

Hi guys,
your help please with a seemingly simple problem.

I’ve used templates for years. Admittedly they have been pretty simple and fairly small but have saved me time.
I know I have had template issues in the past were I have tried to import a template from an earlier version of Cubase to a newer version, so I don’t do that anymore.
Recently, I have upgraded to Cubase 10.5 Pro and decided to write and develop a Full Production Template from scratch. The idea being that I can make smaller, more specific templates from the Full Production Template as and when I need to, thereby building a number of dedicated templates to speed up my workflow.

My Full Production Template consists of around 15 Kontakt 5 VST instruments, 10 FX (Cubase and 3rd Party), Group buses, Stems, Audio channels (already routed to my audio interface), MIDI channels already routed and set up. Then I have a Ruler, Arranger and chord tracks. There’s nothing really technical. Incidentally, the VSTis and the FX are all disabled in the Full Production Template and I enable them as and when I want to use them.

The curious thing is… my template project can take anytime from 25 seconds to load and around 8-9 minutes or just hangs (and shows the last item its finished or was stuck on). In this instance I have to resort to Task Manager to End Process and start again. Subsequently, it usually loads quickly with no issues. I’ve logged my session start times and there’s no pattern to it! It seems random!
What is consistent though is the time from double-clicking the Cubase shortcut to displaying the Cubase menu is around 15 seconds (19/20 times 1 time it just hung).

This whole template workflow is stifling my creativity!

Clearly, there’s something wrong but I can’t for the life of my figure it out! :blush: Hence the post.

I have watched many videos on templates and I’m confident I’m following the correct procedure. It is pretty straight forward.

Am I missing a template technique for large number of VSTis? :blush: :unamused: The VSTis and FX are disabled in the saved template. Are they really disabled though?

Thanks for reading

I forgot to mention, the save times can be horrendous too.

You say the VSTis and FX are disabled…how are you disabling them? Are the tracks disabled?

I don’t know the exact number of tracks and VSTis I have in my Templates, probably more Audio tracks and fewer VSTis than yours but I have all but three Audio tracks and EZDrummer disabled (the tracks). I have no issues as long as they’re all disabled. If they’re not they still load but do take a long time.

I just want to confirm that your problem does NOT deal with “large track count projects” which may include yours and

  1. File>export selected tracks
  2. File>import tracks from project

If you used a few hundred instances meaning track counts of Kontakt (it doesn’t matter if enabled or disabled) and attempted to do either 1 or 2 above you would either wait a long time depending on the size, or often crash with task manager showing non responsive.

This is a bug and is fixed in the next update.

Assuming it’s not the above issue, would the best solution be to use process of elimination? Or are the issues too random?

Before that, of course trash your preferences and let Cubase re-build. Also if you have a prior version of Cubase installed, temporarily re-name it before re-building. I mention this because in the past I have had prior Cubase version preferences and other Cubase data imported into my current version, therefore importing potential corrupted project data. The goal is to start with a fresh virgin template.

Subsequently, it usually loads quickly with no issues. I’ve logged my session start times and there’s no pattern to it! It seems random!

That should manifest some clues to users with good PC knowledge.

Thank you for your replies greggybud and planarchist. :+1:

To be clear
I have a clean install of Cubase 10.5 Pro on a brand new music PC with i7 and 32 GB RAM running Windows 10 Home Edition.
For virus protection, I run Windows Defender ONLY when I access the internet and turn it off after. The internet connection is on a switch so I can turn it off and easily.

Good point. I select the VSTi track in the Inspector, right click and select Disable. The VSTi gets greyed-out. For the FX, I click the Bypass button on the insert and the effect is greyed-out. The same is done with the Group track effects, the insert effects are bypassed until required. There is ONE bar of MIDI which is not disabled. I use this for count-ins. I have now muted that.

My audio tracks are NOT disabled but the effects are bypassed. :fearful:
However, I have just tried disabling ALL my audio tracks and unfortunately, has made no difference!

I have a total of 130 tracks.

My wait times are opening projects from the Cubase menu; File > Recent Projects

It is a brand new dedicated Cubase PC

I will try and start without preferences

No!!! Wait!!! …
I have just re-booted and tried again… Wow! :smiley: :slight_smile:

From double-clicking the Cubase shortcut to Cubase Menu = 12 seconds Always been the same. :+1::sunglasses:
However …
From Steinberg Hub > More > select my Full Production Template > Create > Test Folder = 12 seconds consistent in the 10 test runs this morning!

This is much better. Now I know I have a stable and reliable template to build from. So, I know that it will take time to load when I start adding tracks with data/recording etc. But I’m in control and now know what I was doing was causing my problem which was simply NOT disabling my audio tracks (even though there was no recordings) and bypassing the effects was not enough.

Thanks for your help guys! :+1::+1::sunglasses::ok_hand:

Glad you got your problem sorted out but for reference simply clicking the bypass button on FX does NOT disable them. You need to alt-click to disable any FX, otherwise you’re bypassing them but leaving them loaded (which may use resources and cause latency/compensation issues).

Ok… thanks :smiley: