What limts N5's rendering time?

I always assumed that if I had a faster computer, the time it would take to render a project would be faster. But instead I’m finding with Nuendo 5.5.4 that my new cpu isn’t even using 25% of its capacity and it’s still taking a long time to render.

So what is it that limits rendering time?

Memory subsystem?

Drive speed?
When I put in SSD drives rather than hd’s in one machine export times went down a lot!

Oversampling - some plugins can make an offline bounce longer than a realtime bounce…

But still, that is entirely related to the CPU power of the computer.

As others have said, it’s the slowest component (so to speak) in your computer which will determine the speed.
Disc access, memory and other “things” aren’t as powerfull as the CPU often is.


UAD2 for example :frowning:

Right: assuming there’s no issue with software and hardware, then in principle a machine should simply process as fast as it can. I should be seeing all my CPU’s maxing out in Task Manager. And as I mentioned I don’t.

So of course any processing demands from oversampling, or other calculation intensive processing would simply max out the CPUs. AFAIK, that’s what the number crunching is for. All my rendering is ITB; no external cards or VEP involved.

And I’m rendering a complex mix to a simple stereo track AND to SSD; so I don’t think that’s a problem since I can record lots of tracks on that drive without issues.

I tested the system with Intel’s Processor Diagnostic tool and Sandra and it passes with flying colors. And at 38 GB/sec, I don’t think the Memory subsystem is an issue. I haven’t completely ruled out hardware, but it’s very unlikely.

So what’s left is software: Windows 7-64? Nuendo? (in the Nuendo settings, Multi Processing is ON and Steinberg Audio Power Scheme is ON.) Some system-wide settings? A mystery…

I think you arer jumping conclusions.
You can have as much power (CPU) as you want, if the disc throughput is slow, the system has to wait for audio to be written to disc, thereby using little or no CPU, simply because the CPU is waiting for something else.
Only if the CPU turns out to be the weakest/slowest link within your system, you will see it max out.


UAD plugs certainly do seem to slow things down a lot.

My impression is that Nuendo offline rendering has got slower and slower over the years. despite the fact that my mixes are of similar size and complexity, sample rate, bit depth, and the computer is now 8-core 2.8 gHz when 10 years ago it was a one core 1gHz…

I did some work in Logic today - very fast rendering.

Is that the only drive involved in the process, or do you read from a different drive?

That’s a very valid point. While the mix is simple, it is using a number of sample-playback VSTi’s (Play, Omnisphere, etc…). I tried freezing the VSTi’s and rendering to a RAMDisk, but it made no appreciable difference, but then I’m still streaming data from some hard disk.

I’ll have to try putting a project together that only uses virtual instruments (no samples or recorded tracks) and see how that goes.

I have noticed this as well.
Many plugs use oversampling when rendering these days.
Especially limiters seem to need oversampling to prevent peaks.
Obviously it needs a lot of CPU.

Try to render a session with Waves L2 (no oversampling) or Voxengo Elephant (8*Oversampling or Auto setting) and you will see the difference.


the quickest way to increase the speed of the export is to up the buffer setting to maximum. the difference is incredible. here’s some screenshots of a 50 minute hairy bikers episode export starting with buffer setting 32 then doubling up each time to 1024.

so, for a 50 minute export it can take 11 seconds or >5 minutes depending on buffer setting.



Wow, I’m gonna have to try this this tonight! I’m often waiting for up to 10 minutes for the mixdown to finish, so this would be a real time saver.



Wow. Thanks, Max.


:astonished: WOW. Thank you Max!!

it’s why i’ve asked for the engine to intelligently increase the buffer setting to maximum for all exports, irrespective of the playback buffer setting.

Very good feature request!

Unfortunately Timo and the others won’t acknowledge your request so we’ll never know until the next version if they’ve heard your request.