when will steinberg fix the audio/plugin-menu bug?

hi :slight_smile:

there is a bug, maybe a minor one but still VERY irritating in my oppinion, that is reported and should have been fixed by now that really bothers me.

the bug is locaed on the aduio/plugin-submenus. when one of those sub-menus got so big that you have to scroll and arrows show for scrolling, then the content on the menus dissapear. you can get the text back by hovering the mouse over the main content, but the content that you have to scroll for, that is the conteant that is further down on the sub-menu, that is impossible to get the text to show for. the links hare still there so if you click anywhere there then the plugin will show up, but you dont know what it is since you cant see or read anything.

sure, there are other places on cubase where you can se the menus without this bug. but often you go to the audio/plugins-sumbenys to look for a certain plugin, at least i do that. and well i dont think i have so say much more, its VERY irritating!!

and after what i have read about it, it has been reported to steinberg ages ago and should have been included in the 10.0.15 - update…and is still not included in the latest 10.0.30 update.

so yeah the bottom-line and question: when will this bug be fixed? or is it soo small so it is always down-prioritised?? it doesnt look any other way to me.

anyone who knows anything about this? or agrees and disagrees? and yes i know steinberg is busy, busy and has tons of other bigger and bader bugs but i still dont think thats an excuse.

There is a fix for this but it requires some effort on your part. The problem may seem like it belongs to Steinberg but it doesn’t. You created the messy sub menus when you installed your plugins. The fix is not for everyone but it can be done. By you. Here is the short version of the fix and I will assume you are running in 64bit and using 64bit plugins:

Open a Project. Open your VST Plug-in Manager window under the Studio tab. First, go to the upper far right hand corner of this window. Click on the white arrowhead and a drop down window will appear - Leave the ‘Default’ line clicked, and then click on ‘Sort by Vendor’. Remember, too that the large VST window to the left will always show the plugins in ALPHABETICAL order. Take a look at what you have listed. You will see DUPLICATES of the same plugin - BUT - one will be the VST 2.4 versions and the other will be the VST 3.6XX version. This should explain the rather large ‘OTHER’ sub header you see in the right hand column. You want to remove the VST 2.4 version of the DUPLICATE plugin - and - as you do this - you will see that your list of plugins has sorted itself, and that the large ‘OTHER’ folder is gone.

Alright, this is where the effort on your part begins, and I’ll share with you that if you clean up these duplicate plugins - that you are not using - then your DAW will load plugins much more quickly and there will even be more room on your HD.

So click on a particular DUPLICATE plugin, the VST 2.4 version in this case. The lower window will show you where this plugin is located. Now click on the DUPLICATE VST 3.6XX version of this plugin an see where it is located. You should see that they are located in two different folders. Go to the VST 2.4 folder, create a folder on your Desktop that describes what it will contain, and then drag all these plugins into this folder after YOU CLOSE THE VST PLUG-IN MANAGER. Try just doing only one first if you are concerned about losing a needed plugin. Reopen the VST Plug-in Manager and find the VST 3.6XX version of this plugin. Is the VST 2.4 plug-in gone?

OK, that’s the fix, keep going until you clear out all the unused and unnecessary DUPLICATE plug-in versions. And yep, I deleted all the VST2.4 plugins that were not being used. No issues.

Here’s a pic of my VST Plugin Manager after cleaning house:

thank you very much mr.roos for trying to help out. but your theories above does not hold water on a number of accounts:

the bug is an noticed bug by steinberg themselfs and that a long time ago. they have just down-prioritzed it since then wich is very annoying. so yes it is steinbergs fault. this thing worked on the 5.1 version i ran before. and it shall work. as a user you shall just install your effects and that will be it. if there are plenty then you shall be able to scroll and still see the plugins you scrolled down to. anything else is a bug.

i have never installed two vst-versions of the same plugin(s), been very carefully to avoid that in my installs, and therefore there are no duplicates among my effects, not even one. and thereby your thesis falls apart. but you shall be able to install both versions if you like and cubase shall handle it without the text in long menus dissapear. its so much a classical bug its almost a parody of itself.

so the assumptions you did about the circumstances and what i have done is not correct, and the bug will be there until steinberg decides to fix it. just as i wrote.

but i thank you again for your great effort even though it was not fruitful.

First, it would help to know your operating system and a bit about your PC.

Considering this is important to you, what I would do is create a clear step-by-step reproduction. Include attachments.

“audio plug-in sub menus.” “audio/plugins-sumbenys?” You mean from the top bar, Audio>plug-ins? So to your knowledge this is exclusive to Audio>plug-ins? The issue isn’t generated from any 3 mix consoles, the project page, or any function that would prompt an opening of VST/VSTI’s other than Audio>plug-ins?

Who at Steinberg noticed it? Who said it was “down prioritized?” Honestly, that doesn’t sound like a Steinberg rep. A Steinberg representative on a forum acknowledged it and if so do you know who? Called or messaged Steinberg Tech support? Perhaps there a forum link where this was discussed? Something that long ago should have been addressed, however as beta testing, I can’t find any entry for it so either I’m not privy to view it, (for something like this I doubt that) I don’t understand the issue or it’s connected to something larger, or it’s not in the data base.

This is why I like the Right Pane VST plugin menu. You can make and organize your own menu and drag in effects as needed. I also like the snapshots of the interfaces: it gives me a faster recall of what the plugin is than reading the name. With the “+” and “-” buttons to expand or collapse all, and the triangles in the menus (and sub-menus) I find navigating in this pane to be very quick and efficient. Of course everyone has their own preferences, but you might try this. I think it’s faster than using the Audio > Plugins > Default (or personal) route. Just my personal opinion.

greggybud:
no i havent noticed it yet in any other place than audio -> plugins submenus. yes thats from the top bar down. i have begun to go through cubase 10 now and it will take a will to go through the thick manual try things out and so on. but if anything else like this shows up i write something about it here.

i search around for others who have experienced this on the net. read about it in a couple of sites/forums (dont remember whch) but there it was talk about that it had been reported a long time ago to steinberg and since nothing have happpened they shall do it again. so then why shall i also report it. and therefor i guess that steinberg has knowledge about it. and if so and why they dont do anythng? well your guess is then as good as mine. ok?

and why shall users report everything? does not steinberg notice their own bugs? they surely must also have beta-testers. so in any case there is knowledge about this bug, its not something new. and if its known and this has still not reached steinberg in any way, i see that as very strange?? does that make it a bit clearer for you?

and the issue, you dont get that? well in your picutre none of the submenus has so meny plugins that you have to scroll, and therefor the bug will not appear, ok? if you now should replicate the issue then you have to fill at least one of the submenus with so many plugins that the scroll-arrows appear and then you will see that the graphic side of things does not work, as i tried to describe above. if you dont think its an issue that you cant see some of the plugins on those subfolders, than you have another mindset than me. in any case, its a bug and it should be fixed, and again and to my understanding it have been reported. i dont have any personal guarantee that it acually have been reported, but after all this talk i thought someone did. and no i dont know anybody that work on steinberg, or knows who this was reported to, if it now was reported.

but if steinberg knows about it and havent done anything about it because there are bigger problems to solve, is that so hard to believe? many software companies operate that way. our dear microsoft for instance. they have bugs that are over 30 years old that has been down-prioritized countless of times, and they will as i guess you can understand most likely never fixed. i dont think steinberg is better in anyway regarding that then any other software-company.

but that is not the issue. the issue is that this bug is there and must be fixed. then we can argue for all eternity about whos bo blame or who knows what. its pointless. if it gets fixed i dont care about that. and i will therefor not discuss the report/blame-issue any further, its now as i see it sorted out.

lets instead be creative and solve this. anything else is waste of time.

ok drifted away a bit there but there you have it.

SF_Green :
yeah on other places in cuabase where these plugins appear there is not problem, not as i have encountered yet anyway. so you are right in the meantime as long as this bug exists you have to go to other places where it works thats for sure. its not a functional bug but a graphic one. its hard to choose a plugin that you cant see the link for, right?

Okay just confirming. I have seen something similar years ago, but it wasn’t in this menu, and it was fixed later.

IMO, it should be reported again. Please keep in mind in a forum there can be dozens of posts about a bug, but that doesn’t always or necessarily mean a Steinberg representative will report it. Yes, they do read the forums. And often, even where there are dozens of posts about a bug, every user assumes it has been reported by someone else, however the end result is that no one actually reported it! Again, there can be a lot of talk and you assume…but end result is no one did anything. I’m not saying this is what happened here, but that does happen.

Well, I’m a beta tester, and as said I looked and couldn’t find an entry. I’m not saying it hasn’t been reported, I’m saying I can’t find any such issue after doing a search with some key words. Also consider sending a PM to Martin or Steve too to see if they are familiar with this issue.

I understand the issue. My attachment is to make perfectly clear for a potential data entry plus all users what you are addressing because so many users have so many different names for Cubase nomenclature it often is misunderstood. The Cubase Project Page, seems to have a dozen name substitutes, so depending on the problem it’s always best to clarify functions and names so there are no misunderstandings…especially in a forum with so many different languages. Pictures and .gif recordings, help a lot.

My suggestion is add an attachment or better yet something that records directly to .gif, demonstrating the bug on your PC. Other users who have large number of VST’s can then easily confirm or deny what you are showing on your PC. You said some already did. That doesn’t mean the issue is universal over all platforms. I personally can’t verify it because I’m out of town and even then would have to load a lot of bogus VST’s to generate what is happening to you.

It wouldn’t hurt to make a new post in the general forum with an attachment or .gif and a link to this thread.

Prioritizing is just one reason. However at this point it’s important to confirm it’s a known bug meaning it’s in the data base. At this point, I can’t find any. That is why its so important to show attachments, any reproductions, and web links with other users experiencing the same problem. And remember as I discovered long ago, a seemingly simple small fix like just a toggle switch somewhere doesn’t necessarily mean it’s simple for someone coding it.

I understand your frustration. I’m just suggesting an avenue for you to take if the issue means that much to you.

Please don’t forget to add your system information at the bottom. As it stands, no one even knows if this is PC, Mac or both.

My suggestion is add an attachment or better yet something that records directly to .gif, demonstrating the bug on your PC. Other users who have large number of VST’s can then easily confirm or deny what you are showing on your PC. You said some already did. That doesn’t mean the issue is universal over all platforms. I personally can’t verify it because I’m out of town and even then would have to load a lot of bogus VST’s to generate what is happening to you.

well i have now added a foot-note to my messages or signature as steinberg like to call it. i have also made three screen-dumps that i think shall describe this bug. it had to be three dumps because it is sort of three phases. and it is as follows:

i have choosen eq:s as my example-plugins since i have lots of those and need to scroll (but its the same with any menu that has plenty of plugins and need to scroll), here we go:

  1. when you have choosen the audio->plugins-eq, the eq-submenu shows but the text-links in that menu is invisible:
  2. You can make the text appear by hovering over the links with the mouse but only in the part of the mnu that you dont have to scroll to, so no scrolling yet:
  3. now you scroll down to the part menu that you need to scroll to, and here it does not help if you hover over the links, they are invisible and stay invisible. and it is here that the bug really appears.

    …and again if you dont have enough plugins in some category so you dont have to scroll the bug does not appear at all. so its a graphical bug that has to do with scrolling and is located at the audi-plugins subfolders.

and one other important thing, the links in the large submenu(s) are working, you can click somewhere and the corresponding plugin will start. but the problem is, as i hope you understand now, you cant see them. especially not the ones that you have to scroll down to, there is no way to make them visible. and to choose plugins blindly is not optimal. but again, they do work.

dont know about other platforms but its a problem for windows or at least windows 7x64 that i run. and then maybe also other windows-versions.

that is all i have time to do. i hope it will be to some help.

OK, much clearer with the pics: thanks for posting. I wasn’t understanding correctly. I have never seen the problem you are experiencing. Have you heard from anyone who could reproduce this issue?

I would check to see what you can do on your end first, since it doesn’t seem like too many other people have this problem so far. Have you checked MSI’s site to see if there is an updated driver and/or firmware for your built in graphics and MOBO? If you’re up to date and still having issues, see if you can borrow or otherwise get hold of a graphics card and test this issue using that instead of your built in graphics. Again, download the latest drivers if you do that.

Here’s what I get on large menus. I can scroll down a long list to the bottom and everything’s visible. Just for a data point.

Dynamics menu
https://drive.google.com/file/d/16jxejTcrQfsjm_d1oLYBtL8Jhb76dlVa/view?usp=sharing

EQ menu
https://drive.google.com/file/d/1inHoFH2GhMVt7eLtp-0ZOfkyBYp8x35i/view?usp=sharing

Good luck!
Cheers

SF_Green:
hmm in my searches online i have come across a few ppl that has the same problem. but as you say if it were a problem on a wider scale then you should have heard more about here on steinbergs forum. but one thing that i really dont understand if its now my MOBO and/or its buit in graphic card that is at fault, how can that be? i mean everything that i have looked at so far (beginning to go through the cubase pro 10 beast) had looked ok. long plugin-menus in other places in cubase looks ok. i mean if there were some fault with one of those components due to old drivers or so, then it should be more graphics errors. not just one specifc area of submenus in one place in cubase. otherwise and also with other program in general the graphics is more than ok. fantastic performance for an built in card. so i cant get my ahead around that and have never heard of anything like that.

but ok…i shall go to the msi site and see if i can meassure up som drivers, update and cross my fingers :smiley: but if have to be in a while because im tangled up in other stuff for a while now.

but i report back here when i have dont that.

Thanks for the screenshots. On windows 7, I have experienced similar issues or perhaps the same issue in the beta phase with other drop-down windows in C10, however it’s always caught before release.

Also, if I remember correctly this only happened on windows 7.

My hesitation now is whether to load up a bunch of VSTs to attempt similar results, or take your jpegs and use them for an entry.

Your graphics is your motherboard, I’m using a Ti750. When I’m back in my project studio, I’ll figure which route to peruse. Again, with these screenshots and description, it makes the issue much more clear. Thanks!

cyberpunx i sent a PM for a few more questions.