Where did my glissando go?

This is what I have in “Write mode”:

But this is what I see in “Print mode”:

The glissando disappeared from the bottom notes. How can I fix it?

\


How I did it?


The F is a normal diamond notehead
The C is a normal note.
The E is a grace note of B (set to “Grace note before barline”)
The B is a normal note
I selected the F and E and added a gliss
I then selected the C and B and added a gliss.
All seemed fine in write mode, and then not so fine in print mode.

I was able to hack it by using a new voice for the e instead of a grace note.

The only problem now is that the E is stuck on beat 4 instead of being “as close as possible” to the barline. It looks weird when it comes to aligning with other instruments.

I would love a better a solution if it’s available.

You can adjust the position of the note (e) --without repositioning the beat–in Engrave Mode.

If this is where i’m supposed to change the position than no matter what number I put, nothing happens.
What am I doing wrong?

You need to turn on the note spacing tool (left panel in Engrave Mode). From there I think you need the little circle next to the note, as opposed to the square blob above or below it. Alt+arrows will move the note left or right.

Correction- grab the square blob above the note and a circle will magically appear immediately next to the note. Select the circle and use Alt+arrows to shunt it.

Oh, cool! thanks!