Where is the tempo hiding now?

I’m a bit baffled. Just started using N10. Been using Nuendo forever and always just use F2 to open the transport panel to set my tempo or check it. It’s missing now. Is there a way to show and set tempo without creating a tempo track? I feel stupid. The GUI is really throwing me off. It’s like a whole different DAW now (in some ways).

Works normally here.

Right click on the transport controls at the bottom and turn on Tempo & Time Signature?

I figured it out. It was turned on but I also had hiDPI turned on as well which made everything way too big, so it was there, but off the screen somewhere. I’ve got a 2K monitor. I turned off hiDPI and I finally was able to see the tempo and time signature.
I think it will take a bit to get used to all the GUI changes. It’s a pretty big difference.

Bro, who’s your photographer? I need a photo taken and love his work!

Uhm, I think his name is “my left hand”