Where`s my click sound?

Ive been a Cubase user for many many years, so this is very strange to me indeed. But in 9.5 I dont hear any sound from my click, no matter what I do in the metronome setup. Anyone else had this problem, or know what I must do? W10.

The metronome set-up is different for 9.5, have you checked the new section in the manual?

https://steinberg.help/cubase_pro_artist/v9.5/en/cubase_nuendo/topics/playback/playback_metronome_setup_r.html?hl=metronome

Secondly, are you using the Control Room feature? If so you’ll need to enable the click there too.