White Background for PNG?

Hi all,

does anyone know the solution for unreadable PNGs because of the transparent background?
I’m using Edge, and any slices exported from Dorico are black on black in my browser…
Adding a switch in Dorico to set background to white would be fabulous… Dorico’s Devs are likely more agile than Microsoft’s (or Google’s…)


You only get transparent PNGs if they are colour, I believe. Setting to Mono will give black on white.

Super, thx, will try!


Well, today I have this problem. I want a white background, but I also need some colored noteheads. I guess there isn’t a way to maintain a white background and still export in color. I’m thinking about setting up a folder action in Finder and Automator to remove transparency. Anyone has a clue about how to do this?

Will using an alternate file type that does not allow transparency (JPG ?) allow you to have both?

1 Like

There is a freeware program called ImageMagick that has command line features that can probably be used with Automator.

1 Like

Unfortunately, JPG is not in Dorico’s supported options. Since this is to use in conjunction with Max, and those images should be transmitted over a network, I think using TIFF is a bit overkill. I could also convert them using another tool, but since I’m going to be exporting versions continuously, I’d rather have a native option, hence the alternative of automating it via Automator.
@Craig_F thank you for the tip! Will check it out!

Presumably this means you are placing the images on a non-white background?

If your document is white by nature, the transparency will not cause an issue in the end. (Although I don’t disagree that having an option for a white background (but also transparency) would be good.)

Indeed, that was more of less the solution. The thing is that this PNG was meant to be superimposed over another image, effectively obfuscating it. What I’ve ended doing was setting the opacity to 0% on the other scores when this one was shown, and setting a white background overall. Thus, problem solved!