Whitelisting plugins in 2.0

I followed the directions here:

https://helpcenter.steinberg.de/hc/en-us/articles/206899770

…and created a whitelist with plugins I want to use, like so:

Kontakt 5
Kontakt 5 8out
Kontakt 5 16out
ValhallaRoom_x64
ValhallaPlate_x64

…however, I don’t see these plugins in either the drop-downs for setting up VST instruments, or in the inserts drop-down in the mixer.

Is this still the right process for loading plug-ins? And is there some way to diagnose what plug-ins are loaded, overall? I really want to try a bunch of stuff with the Spitfire string libraries, and see if I can ditch my DAW entirely. :smiley:

You should find that your Dorico 1.x whitelist is automatically migrated over to Dorico 2. Look in /Users/your-username/Library/Preferences/VSTAudioEngine2 and you should find the vst2whitelist.txt file there. Make sure it contains the instruments you want to use, and that should be sufficient.

Thanks Daniel. I didn’t whitelist anything in 1.0, I’m doing this new in 2.0, so I’m not sure what, if anything, migrated over.

I’m on PC so the path I’m looking in is:

C:\Users\courtney\AppData\Roaming\Steinberg\VSTAudioEngine2_64

The vst2whitelist.txt file is in there, and that’s where I’m deleting the files indicated by the directions linked above. Kontakt (which is working fine in other software, like DP) just doesn’t show up when I try to choose it here:


Unless there’s something I’ve overlooked, I’ll try uninstalling all Doricos and re-installing just D2 to see if that helps.

I can’t remember the exact name of the file, but look for a file inside VSTAudioEngine2_64 with “blacklist” in its name, and delete that – maybe Kontakt has for some reason been blacklisted by the audio engine.

Yep, that’s one I’ve been deleting as well. It doesn’t seem to make any difference. And after quitting Dorico I’ve opened that file to snoop around; it never has any plugins blacklisted.

Would you please open Dorico 2 and choose Help > Create Diagnostic Report. That will create a zip file on your desktop. Please send that to ‘u dot stoermer at steinberg dot de’ and I will have a look at the contained log data.

Thanks Ulf! I sent those. Just to update this thread though, as well, I tried installing Cubase 9.5 and running it as a demo, and seeing if I could get Kontakt running there. I could, using Cubase’s plug-in manager, so I looked at the different folders and files, and what I did was copy the Kontakt and Valhalla related entires from this file:

C:\Users\courtney\AppData\Roaming\Steinberg\Cubase 9.5_64\Vst2xPlugin SearchPaths Cubase.xml

…and then pasted them into this file:

C:\Users\courtney\AppData\Roaming\Steinberg\VSTAudioEngine2_64\Vst2xPlugin SearchPaths VSTAudioEngine2.xml

After doing this, Dorico 2 now presents Kontakt as expected in the VST instruments drop-down and it works fine. I still don’t see Valhalla Room in the inserts drop-down, but I could try poking around in some more .xml files for a while longer.

don’t know if it still applies, and don’t know why, but early on Dorico was most happy with …\Program Files\Common Files\VST2…

…and adding back in a whitelist file gave me Valhalla Room as expected. (Thanks Ulf!) So, in short, the only thing I had do differently from the instructions was to add the paths to the plugins by hand to the Vst2xPlugin SearchPaths VSTAudioEngine2.xml file.

I’ve been trying to get Dorico to recognise Kontakt too but nothing works. It’s immensely frustrating!

I thought Kontakt was supposed to be the one VST2 plug which was explicitly whitelisted for use in Dorico. That does not seem to be true.

I shouldn’t have to be messing around in code just to have the most popular sampler of all time available inside my notation software.

I tried specifying files and paths in Vst2xPlugin Infos VSTAudioEngine.xml and Vst2xPlugin SearchPaths VSTAudioEngine.xml but Dorico simply rewrites the files on restart. I created a whitelist per the instructions given but Dorico seems to ignore it. I deleted blacklist files. I’m sick of messing around now. How do I get this to work?

Please keep calm, we’ll help you with this.
In Dorico, please choose from the main menu Help > Create Diagnostic Report. That will create a zip file on your desktop. Please send it to ‘u dot stoermer at steinberg dot de’.
Also, please post me the installation path of your Kontakt.

Will do.

Thanks, Ulf.

Thanks very much for sorting it, Ulf.

Hello there,

I’ve tried the options above, but still no luck. Also the file Ulf gives as a download in another thread about this (Vst2xPlugin SearchPaths) didn’t fix the issue. Is there another workaround?
Looking forward to get some tips.

Well, I just found out what the real location of the whitelist is (Windows): C:\Program Files>Steinberg>Dorico2>VSTAudioEngine>Components

Here you will find a vst2whitelist.txt and this is the one Dorico2 reads at start-up. This worked for me, hopefully it helps you too.

But bear in mind, Dorico uses 2 whitelists and merges them. The one under C:\Program Files\Steinberg\Dorico2\VSTAudioEngine\Components is the “factory” whitelist and may get overwritten during updates. Therefore it is better to use instead the “user” whitelist that goes into C:\Users<yourname>\AppData\Roaming\Steinberg\VSTAudioEngine2_64
Please also read https://helpcenter.steinberg.de/hc/en-us/articles/206899770-How-to-use-VST2-plug-ins-in-Dorico

Didn’t know that, but the vst2whitelist in the user folder somehow doesn’t function on my side. I guess I need to find out where it goes wrong.