Whole mix is getting recorded when I try to record a track.

I’m quite new to cubase, so I don’t know if the problem has been answered yet.
I’m using a Steinberg UR22 MKII, and even with the mix knob turned at max to the input, whole making sure that “Listen to this device” is turned off, when I try to record something on track 2, track 1 is getting caught in the input.
I think another problem is linked to this: When I turn the direct monitoring on, i’ve got an echo with a latency close to my input latency (16ms+19ms).
Any way to solve this? (And the first one in particular…)
Thanks in advance!

    • Disable loopback on your interface
    • When monitoring direct, don´t monitor via Cuabse also.

Thanks a lot. Now that I further googled “disable loopback”, I found it was actually in the user’s manual of the interface.