Why are instruments not properly bracketed in Full Score view?

My bassoons are bracketed separately from the rest of the woodwinds, the tuba isn’t bracketed with the rest of the brass, and the timpani and bass drum staves aren’t bracketed together. I have to go into Engrave mode and apply the proper bracketing manually.

Is this an artifact of conversion of the score from version 2 to version 3, perhaps?

Highly unlikely. What’s set in Engraving Options > Brackets and Braces?

Ensemble type: Orchestral (The graphic of which even shows the bassoon grouped with the rest of the woodwinds in its example.)

If I create new players and assign the problem instrument types to them, then they get properly bracketed.

I think my score just got screwed up when personnel at Steinberg had to convert it to version 3 for me. (Dorico 3 failed to convert my score, it would get to 60% then hang.)

There was no “conversion” involved – merely fixing up the ranges of instruments that didn’t have any. There was no effect on bracketing and bracing. Check that you don’t already have bracket and bracing changes in Engrave mode, and delete them to get back to the default state.

A bracketing change would show up as such in the score, yes?

For example, Dorico doesn’t bracket timpani and bass drums by default. If I go into Engrave mode and bracket them, then I see a big, fat flag on my score, indicating this edit.

I’ve never seen any such flag for my bassoons or tuba. Which stands to reason, because until now, my only experience with Dorico’s Engrave mode has been just looking at it, thinking “Wow, that looks complicated,” and promptly switching back to Write or Play mode.

Yes, a bracketing change would show a signpost on the top staff, assuming you have those signposts shown.

Right. And as I wrote, there was never any such flag for my bassoons or my tuba, although one does pop up when I bracket my drums.

Anyway, it’s not a big deal for me, anymore. Again, when I create new players and assign to them the instruments in question, they get properly bracketed. I’ve already transferred the music to the new staves, and removed the errant staves from my score. Problem solved.

This sounds like one of those situations where, if it happens once and I can fix it, I don’t worry about it. If it happens again and I can’t figure out why, then I decide whether to report it.

That’s cool, if you want to do that.

Me, I report what I think are potential bugs, regardless of whether I can work around them. As a professional software engineer myself, that’s what I want and expect from people who use the SDKs and applications that I write.

I admit, I definitely could have made some mistake that accounts for this. I would urge anyone who cares to indulge me to load this project, and let me know why the bassoons and the tuba aren’t bracketed with the rest of the woodwinds and brass, respectively:

https://www.miloonline.net/stash/dorico/jacked_brackets.dorico

Don’t know how you made them, but Tuba and Bassoons were listed as fretted instruments in Layout options.
If you do change instrument in Setup on the three all is good.

Jesper
jacked_brackets.dorico.zip (427 KB)

Hey Milo,

I have no idea why this sometimes happens, but for whatever it’s worth, I’ve noticed this very often in Dorico 2. I always assumed it was because I was doing some pre-Dorico3-condensing hacks, i.e. putting two flutes on one stave rather than having separate instruments in setup and galley view.

I also have no idea why, when you have sub-brackets set for like instruments, you get this on violins and horns, but not in other places. (I prefer sub-brackets on all woodwind doubles, personally, so for instance piccolos and flutes sub-bracketed together. I frequently do this manually in Engrave mode; the change usually sticks on subsequent pages until an instrument change is made, at which point I have to pop into Engrave again. Then again, I too spend very little time in Engrave mode (so far sub-bracketing is the main use case for me), and it’s very possible I’ve set things up improperly and may be creating a bit more work for myself here than necessary.)

When doing multiple divisi staves on the strings, sub-brackets always get jacked upon return to unison, in my experience. So for instance, when adding a divisi stave, Violins I and II are frequently still sub-bracketed together, even though it would frequently be visually less confusing to only sub-bracket the divisi staves, and upon return to unison (even with no manual changes in Engrave), Violins I and Violins II suddenly each get a sub-bracket of their own, rather than returning to being sub-bracketed together. It ain’t hard to fix this in Engrave mode, but it would be nice if we never had to, or at least if it was a lot less often (I divisi frequently).

You mentioned that creating new instruments results in proper bracketing. Here’s another little quirk I noticed when playing with your file: If you just select for instance the bassoon card, and then “change instrument” to bassoon (as nonsensical as that sounds), it brackets properly. That’s what I did in the attached example; not sure if it’s any quicker/easier than your hack. Note: this doesn’t seem to work on the percussion; for that I know of no way except manually in Engrave, or possibly using your create-a-new-instrument hack, which I haven’t tried but will keep in mind for the future.
whacked_brackets.dorico.zip (745 KB)

Jesper was quicker on the ball than I. But I’m confused; where did you see the fretted instrument thing in layout options? That’s a new one on me and after poking around a bit again in the file Milo posted, I’m stumped.

Here:

Thanks!

Yeah, weird. I made them in the normal fashion, e.g. Add Solo Player -> Woodwinds -> Bassoon.

I loaded a couple of older project files into Dorico 2, and the bad bracketing was there in both of them. I have no idea how it happened. shrug

Thanks!