Why CPU Overloaded in Cubase?

Hi,
My CPU usage is about 30% in Task Manager, but 100% in Cubase. What’s the problem?
Thank you for your help.

The Audio Performance meter in Cubase is not a CPU meter, it is an indication of how efficient your computer is at playing back and rendering audio in real time. there are many reasons why your meter can peak. Slow hard drive, inefficient mother board, lack of memory, heavy VSTi using one core of your CPU, it could be any of these reasons. Try disabling some VST effects or instruments and see if you can work out which one. Make sure your power settings are set to always on. Its not all about CPU head room. Have Fun :slight_smile:

Increase the asio buffer size.

Not enough information! When does it start to max out? When you start an empty template or after you load like a 1000 instrument tracks?

cubase does not know how to share resources or load balance…

This could mean that if you have one channel with some very heavy vsts, (yes, just one channel) if will give you this overload… - It cannot share one channel with multiple cores/cpus… - a problem that will have to be solved at some point but now cubase 10 is a more pressing problem…

example: you can have hundreds of tracks with vsts and it will run fine… but if you have 1 channel with super heavy vsts, you will get an overload…

so, for a short answer to your question: it is not coded as well as it should be…

how it should be:


(balancing system = resource manager/distributor)
edit: i retract the bad coded part- because who could have foretold that vsts would become so cpu intensive over time… now steinberg needs to adjust to the current time…)

Thank you for your comments.
I used some plug-ins for 20 vocal tracks at 96kHz. It works fine if I turn off several plug-ins or convert to 48 kHz, but I can’t believe my computer is having such a hard time.

I’m using high performance mode, high asio guard, full buffer size.

Take a look: https://www.steinberg.net/forums/viewtopic.php?f=283&t=141259
Maybe this explains many things about your performance.

1 Like

I’ve got the same issue over here on my i9 Intel 16 core… Nuendo is peaking my actual cpu usage is 15%(monitoring program) all running on nmve drives which show about 5 % utilization (monitoring program) with 124 gig memory. I take the same project setup with plugins put it in Studio one… and it is at 15% cpu utilization and works fine… yea…not a machine problem… its Nuendo Problem. Please fix this because I’m not going to fight with this much longer. I just want to make music and at this point I going to use what works with consistency…

1 Like

Well, it’s 2021 now
Cubase Pro 11
Halion Sonic SE 3
Set samplerate to 44KHz, 2048 ASIO buffer safe mode on my soundcard
Got a e5 Xeon with 6 cores, 12 threads, 32GB of RAM, sound data disk is SSD

Still when hitting a sinlge chord with 3 notes and changing to another chord of 3 notes with some sounds, the audio stutters and CPU spikes like hell.
I’ve got plenty other VSTi’s doing more crazy sounds but not above 15% CPU.
So… It must be efficiency in programming…

And we’re finally there. It seems to be specific patches that use enormous amounts of processing and voices, even some voice knop where you can add something like 1.4 or 2.8 voices (harmonics I guess), setting them back nearly not changing the sound, it reduces spikes a lot.

Thank you. This fixed my problem. I had a Groove Agent track that would play very slow and chunky. I saw your recommendation and remembered that I had changed my buffer size to 8 for JamKazam. Changing the buffer size to 2048 samples made things work as expected. Now I know that the buffer size is something that isn’t just set and forget.

This issue in not fixed at all for me. Currently running 32 plugins and Audio Performance meter in Cubase is at 99% while my cpu is at 33%. I think this is a general Cubase failure in it´s use of resources. I have found that with VEP 7 (Vienna Ensemble Pro) I can run more than 50 fx pluggins at 55% of Cpu and I still have headroom for more. Seriously, this seems a bad joke from Steinberg after hundreds of euros that I spent in this program. VEP I am using is trial. I am seriously considering to return to Reaper and / or try other Daws like Studio One, Bitwig etc …

2 Likes

That is how it’s been for me with my setup for about 20 years now. It is my ‘normal’. In youtube videos I’ve seen people max out their CPU in the task manager as well, but I never even got close to that. I’d be so thrilled if I could use the other 60% of my cpu.

There are methods which make things worse on my system: long plugin-chains into a group into a track into more groups and so on seems to have a lot more impact here than having the same plugins spread around individual tracks.

Michael

I have several projects in Cubase with Windows 10. One project has about 27 plugins and it takes almost 90% of the “Performance Meter Average” with 17% real CPU.
It makes impossible to work with medium - big projects. I have buffer to 2048 samples at 44.1 Khz. I have ASIO Guard enabled with multi processor also enabled. My PC is brand new i7 - 10th with 8 cores at 2.90 Ghz, SSD disk and 32 Gb RAM. I have tried the same project with the same plugins in Reaper and it only takes 5% of resources with 11% real CPU.

I use a brand new Audient ID4 Mk2.

I cannot believe this is almos useless for mixing or even producing.