Why do instrument tracks take CPU when no notes are playing?

What instrument are you using?

Some instruments include insert and global effects (chorus, reverb, eq, etc), and those of course are processed even if there isn’t any note being played. Otherwise you would lost reverb tails, delay repetitions, etc.

It that is the case and it really makes you angry, be sure to turn off at least the global effects for each track instrument, and put them in proper fx buses in Cubase.

It’s not not just CPU usage, but real output from my audio interface…I’m a user of VB3 organ VSTi, and that gives me the real whirring sound of the Leslie whenever it’s loaded and active, whether or not the arrangement is playing and/or notes are being played.

It even clicks and pops as the drawbar sliders go in and out!

Just like the real thing :smiley:

I don’t think it’s effects, I tested with completely empty instances of Kontakt, Vienna Instruments (vst3) and G-Player. Also, when I tested in Logic even if I have 200 instances it has zero CPU so it seems to be Cubase specific?

To be more specific, I’m just instantiating the sampler ie Kontakt and not loading a patch. But it’s still taking up CPU. My template had 16 multis in it I’m trying to unroll to instruments so I can use my CC121 to eq etc. but I get maxed CPU at around 60-80 instrument tracks. I’ve been using that template for years so there doesn’t seem to be a problem with the actual plugin load, just Cubase doesn’t like having over 80 instrument tracks.

You are using 80 individual Kontakt plug in instances by using instrument tracks, try that in logic and it will fall over.

Hippo

like I said, I just tried it in Logic and it uses 0% CPU. I know it works in practice because one of my friends has his template in Logic with all independent instruments.

Seems like it uses no cpu for AUDIO , not surprising, thats not the same thing the meter in cubase is showing.
Try running a real project and see what happens.

Why are you using instrument tracks rather than the more traditional vst rack and 16 midi in 16 audio out for each kontakt? What limitation happens with the CC121?

Hippo

That “audio” meter is the CPU meter in Logic. You’ll just have to take my word on that if you aren’t familiar with Logic. In Logic it has one meter per CPU core.

The instrument tracks make it so I can use the CC121 to adjust EQ and sends when I have the track selected. That doesn’t work if you use the VST Instrument rack. Also the nice thing with instrument tracks is that they will be in the same order in both the arrange and mixer windows.

BTW I just need Cubase to allow alot of tracks to exist. I only use 20% of the tracks in my template in a given project. I just like having the instruments in there set up already.

Well switch them off, and switch the ones you use on as and when you need them!

Amazing. Even samplitude can’t do that :open_mouth:

That might work, a little extra step but could be worth it for the CC121 bonus. Where do you go to do that though? I can’t find it so far.

Ah, you’re using Instrument Tracks, I never use them so I wouldn’t know if it’s possible?

ah well thanks though. Actually it might not have helped. I like to have them all laid out so I can try out a lot of different sounds and the enabling thing would probably have been a hassle once I was in the groove.

This topic has been visited many times over the years, I remember discussions as far back as 1998 (Cubase VST 3!). But to again cover this…

The Cubase Performance meter (Devices --> VST Performance) is NOT a CPU meter. It does NOT necessarily correspond to your system overhead (processor “crunch” power). It deals with the h/w buffer, specifically TIME, and the probability that given the current buffer size, whether the task(s) at hand are likely to run out of buffer headroom. These “tasks” are influenced by a wide range of things–for example, instantiating an instrument that adds latency (convolution for example), creates additional busses, or anything else that puts pressure on the buffer stream (forcing it to cover more ground in the same amount of time) can cause the meter to rise. And this can be true even though the instrument is not “using” the CPU to play voices. So right away, you see that it is possible to get readings that have little to do with overall CPU load.

A while ago, when everyone was paranoid about how many cores to buy, we were all forced to read and understand this:

http://www.soundonsound.com/sos/jan08/articles/pcmusician_0108.htm

Note in particular this caption in the “Multiple-Threaded Applications” section:

“Here’s some classic multi-processing confusion, illustrated by Cubase 4 running 28 voices of a heavy-duty physically modelled soft synth that together consume almost 100 percent of a single core of this dual-core PC. The high Cubase ‘VST Performance’ meter reading (bottom left) simply indicates that one or more cores is approaching its limit. However, since Cubase 4 is optimised for multi-processing, if you create another track and connect its output to another instance of the same soft synth, you’ll still be able to run a further 28 voices on the other core.”

This is another counter-intuitive realization that occurs if you regard the ASIO meter as a CPU meter–just don’t do that and you’re fine.

For add’l information, also see

http://www.soundonsound.com/sos/oct09/articles/qa1009_1.htm
http://www.steinberg.net/forum/viewtopic.php?p=31737
http://www.cubase.net/phpbb2/viewtopic.php?p=899920&sid=b32a033426f4bea5c7ffefbf9543b637
http://www.cubase.net/phpbb2/viewtopic.php?p=319907&sid=40d9d9c0c6d71ce85c784d2431079c0d

I just went and tested this theory. I created 100 empty Kontakt 4 instrument tracks. Then I added a piano sample to a single one of those Kontakt instrument tracks. The ASIO meter is 100% of course. Now I tried playing the piano, but it is not able to play. So it looks like the ASIO meter is an accurate representation of available power, at least in this case.

At what aiso buffer setting/ sample rate are you at?
Just loaded 100 Kontakt 5 instrument tracks and loaded a piano into K 100, plays fine at aiso 14 percent max.
Thats at 44.1 sampling rate.

Hippo

I’m at 44.1KHz with a buffer of 256. 2008 Mac Pro…I’m sure this particular problem might be less noticeable if you are on Windows since I hear Cubase is tuned more for Windows performance. What buffer/OS are you using?

You will have trouble at 256, its not a power but a clock, timing thing, its all been very well explained in this thread.

Hippo

I don’t think its related to the buffer; after your post I tried my Logic test with a buffer of 32 and it still uses 0% CPU. So I think its just that in Cubase having instrument tracks existing consumes some CPU whether or not they are playing.