Why do my 2-bar repeats look uneven?

Because you removed rests from those bars before adding the bar repeat regions, meaning Dorico has nothing to use for spacing in those bars.

Select the slash note in the 2nd bar of your screenshot, and deactivate “Ends voice” in the Properties panel at the bottom of the window. Or, if it’s not active on that note, find the note or rest somewhere underneath the bar repeat region that does have the property activated.

Dorico automatically hides bar rests in bar repeat regions, so you don’t need to hide them :slight_smile:

Ends voice is not selected on the slash note. How would I find what note or rest is, if that’s the issue - would it be indicated with a unique signpost?

To note: I didn’t delete bars of rests - I had initially notated those first 2 bars twice more, then realizing they could be replaced by two 2-bar repeats, I erased the content in those 4 bars and applied 2-bar repeats.

Perhaps the system is just overfull horizontally then: in Engrave mode, what colour is the system fullness indicator at the right end of the system, and what % fullness is it showing?


Curious – can you share the project? You could save a separate version and delete everything except this system and the systems above/below to minimise how much you’re sharing, if you like. Or message me privately and send it that way.

have you applied any note spacing changes either via a note-spacing change (signpost) or via the note spacing (sub)mode in engrave mode?

I don’t think so. Sending a version of project to Lillie for review.

The culprit (posted publicly for the benefit of anything following along at home) was that the “Ends voice” property was set on the first and third bar rests underneath the bar repeat region.

The way to diagnose it in this instance was to delete the region temporarily, and disable multi-bar rest consolidation to check what was going on when each empty bar is shown separately, rather than glommed together into a single multi-bar rest.

(Which is reassuring, given my first comment)


Thank you Lillie! I interpreted “underneath” to mean later in the song…now I understand. Yes, did what you said - by deleting the 2-bar repeats, then disabling the multi-bar rest consolidation (Layout Options/Players/Bar Rests and multi-bar Rests), I was able to see that strange occurrence. No idea how it got there/how I put it in like that… thanks again!

1 Like