Why does adding repeat flags (1/16 shorthand on 1/8 notes) change beaming?

Is there a good reason for this? It’s quite annoying. It seems they are conceptually quite different…

Are you talking about tremolos? Single-note or multi-note? Perhaps you could provide a minimal example that demonstrates the problem you’re having.

Sorry Daniel. Yes, 'tremolo’s" My string player brain has trouble calling some of these tremolos.

Please see attached.

Wow, that is an amazingly low-resolution image.

Instead of manually changing beaming for that bar, you can adjust your per-flow notation options for beam grouping (assuming you have Dorico Pro?). That way you wouldn’t have to re-beam the bar after changing something, like adding tremolos.

In Dorico, if you find yourself wanting to change how something is notated/where it appears/how notes are beamed or grouped, in most instances there is a default setting (either on a per-flow, per-layout or project-wide basis) that determines this, preventing you having to make manual changes for every occurrence.

Yes, Lillie’s right. You should find that changing the beam grouping options in Notation Options sorts this all out.

Thank you. My fault for not mentioning that I had already examined those notation options. Respectfully, working on a complex 20th century work here and none of those global settings would apply to more than a handful of the measures. Changing them would only undo 90% of the other measures that they do not apply to. Unless there is an option that says “don’t muck with the manual beaming settings”.

Considering how wonderful Dorico is, I admit this is a minor annoyance, but I believe it is a bug, nevertheless.

It would seem there are two bugs here.
https://steinberg.help/dorico/v1/en/dorico/topics/notation_reference/notation_reference_note_rest_grouping_custom_t.html#notation_reference_note_rest_grouping_custom_t

Since I entered the meter with [2+2+2]/4 I would expect that custom beaming to be respected. It wasn’t. And I do think that rebeaming after adding tremolos is a mistake no matter how one slices things up.

But I won’t beat the horse further :slight_smile:
Thanks!

Sorry, but the notation options do apply in this case. [2+2+2]/4 is affected by the ‘Eighth notes (quavers) in quarter note (crotchet) denominator time signatures’ option at the top of the Beam Grouping page of Notation Options. It will beam in groups of four eighths if you set this to ‘Break beams at beat boundaries’, and beam a whole bar together if you have ‘Allow to cross beats’ set.

How are you adding the tremolo, by the way? I find that adding a single-note tremolo doesn’t disturb the beaming at all, even if I’ve split it manually.

Adding the trem to the first note of an isolated group will not rebeam. But if you add it to notes in the middle of the group, the rebeaming occurs. I can send a video if you need confirmation.

I add it by selecting the note, and then hitting the tremolo symbol in the tremolos panel.

Without getting into a discussion of the beaming options, I do feel manually set beams should be respected, no matter what order one decides to place the trem.

Indeed. Like the attached GIF, you mean?


trem.gif

No, rather like this:

Here’s another favorite from my gif collection.

Since you are trying to override the natural compound nature of a 6/4 measure, it is no wonder the program tries to divide it into two groups of three when you apply a rhythmic change (tremolos). You can see this happening if you compare the quarter rests in staves above the part in question with the two-beat rests in those below.

Please provide the project. GIFs are fun, but we need the project to diagnose the problem.

Thank you Daniel. The measure from the first gif is attached as a zipped Dorico file. Let me know if you require more.
FREED_S2_BEAMING.zip (381 KB)

Thanks Derrek. Respectfully, adding a tremolo does not change the rhythmic structure of the measure at all.

If the software is going to reverse manual changes, it would be better not to make those changes available to you at all. Even better is for it to simply respect the operator’s decision and butt out. I realize you may have a different opinion, I respect that but don’t share it.

This may be a bug, in which case I’m confident the programmers will fix it. In the meantime there is a very simple (and, I think, faster) way to enter these signs—don’t use the side panel, use the popover. Shift-R, 1, return. You can also type / or \ instead of 1.

If you create the measure as 3/2, you get the correct beaming right off the bat, and it does not change when you add the tremolo marks.

tremEighths.png
6/4 implies two dotted-half-note divisions (a parallel with 6/8), whereas 3/2 implies three half-note divisions. Dorico simply follows this practice.

I feel like I’ve been a bit slow on the uptake here, so I do apologise for that, sdb2. There is a difference in Dorico’s behaviour depending on whether you use the Repeats panel or you use the Shift+R popover, as John has said a couple of posts before this one. When you use the panel, Dorico goes over the notes on which you’re setting the single-stem tremolo and removes any multi-note tremolos that may be set, but this has the side-effect of removing any custom beam start positions as well. When you use the Shift+R popover, something a bit more subtle is going on that preserves beam start positions. We will definitely look at unifying these two approaches, but in the meantime, there is a simple solution: use the popover instead of the panel. Sorry that it’s taken me a couple of days to catch on here.