Why does b9 #11 chord input appear as alt?

When I entered C7b9#11, Dorico responded with an “alt” chord symbol, which I don’t want.

Unless I missed something, the only way to get it to display as b9 #11 is to select "Never indicate as ‘alt.’ in Engraving Options > Dominant Altered chords > Altered fifths and ninths considered altered chords.

But that makes no sense - I didn’t type “5”.

Dorico should not assume that #11 is the same as b5 because #11 and natural 5 are both present in the H-W diminishied scale (which,like the alt chord-scale, is commonly used for improvising over dominant seventh chords).

If that’s the only way to do it, then it would seem Dorico won’t let me use b9 #11 and “alt” in the same score. I’d consider this a major shortcoming.

So…did I miss something?

Also: are there any plans to let us edit key commands for entering chord symbols, like in Sibelius?

Check Engraving Options -> Chord Symbols


Jesper

Edit: sorry see you already knew that

Bob, when I type C7b9#11, I don’t get Calt.

Can you try starting a new project, going to Engraving Options, clicking ‘Reset to Factory’, and then try typing that chord again to see what result you get with the factory settings?

After “Reset to factory”, I don’t get “alt” - I get b9#11 as expected.

Weird!

How did it happen that b9#11 gave me “alt”? As far as I know, Dorico doesn’t allow that kind of customization - does it? If it does, please explain.

To get rid of that behavior in all projects, do I have to reset to factory as a default and start from scratch with my customizations?

Thanks, Daniel!

I suppose the next thing we have to figure out is what setting is responsible for it. Can you open the Project-Default Chord Symbols dialog (accessed right at the bottom of the Chord Symbols page of Engraving Options) and see whether there are any overrides there that would explain it?

You mean Project Default Appearances - correct?

There’s only one override, and that’s for m(maj7) - see attached image.

As mentioned in the original post, my solution was to select “Never indicate as ‘alt.’” in Engraving Options > Dominant Altered chords > Altered fifths and ninths considered altered chords.

I tested the other two options for altered chords. To summarize:

“Doubly altered fifths and ninths” - F7b9#11 appears as typed

“Doubly altered fifth or ninth” - F7b9#11 appears as typed

“Singly altered fifth and ninth” - F7b9#11 is changed by Dorico to “alt”

As I said before, this last one seems wrong to me, as I didn’t type a 5th.

But the first option will work for me, as it’s unlikely that I’ll ever want that many alterations displayed.


I agree that on the face of it, it seems wrong that ‘Singly altered fifth and ninth’ should produce ‘alt.’. It’s possible I’ve mislabeled that option, and it should say ‘Singly altered fifth or ninth’, though that seems unlikely as a chord with only an altered fifth or an altered ninth is probably stretching the definition a bit far! I’ll look into it further when I get a chance.