Why does Dorico Push the Edited Dynamic Downward?

I know a lot are probably wondering the same thing. That is, why is it that when i double click a dynamic to change it, I type it in, press enter/return and it adds the new dynamic but pushes the old dynamic downward?

For (My attempt) of a clear interpretation of what I’m trying to say I compiled some screenshots to show this.

Bug or Feature change

It’s definitely not a bug; it’s been posted about several times.

Try grouping the dynamics together.

I’ve actually created my own shortcut to increase/decrease dynamic levels to save this from happening.

Well if it’s not a bug it certainly seems pointless…

Sounds very interesting! How were you able to do that, and what’s your suggested shortcuts for it?

Thanks for the response @DanielMuzMurray :pray:t2::musical_note:

1 Like

I think I’ve got Shift+Alt+(+ or -)

I agree that this isn’t the most helpful behaviour in the world. The problem is that Dorico is adding a new dynamic in that circumstance rather than replacing the existing one in the group. It’s something we certainly want to change in future.


That’s great to know Dan thanks a lot. :pray:t2::musical_note:

Seems like a good shortcut :+1:t2:
Thanks for the tip! :pray:t2:

The names of those two options for dynamic levels, just for reference, are described here:

1 Like

Thanks for the precise reference @Lillie_Harris :pray:t2::musical_note:

You know @dspreadbury What would make it much more functional is if you could increase and decrease the Dynamic intensity the same way you would the duration of a note. By selecting the dynamic and pressing (For Window from my POV) Alt+Shift+ Left/Right arrow for one step up/down.
Just a suggestion for it. I’m sure the team knows best about what works for their users.
Thanks again for your support and response Dan! :musical_note::pray:t2:

This key command lengthens/shortens all types of items rhythmically, including gradual dynamics like hairpins. Changing the intensity/volume level of immediate dynamics up or down is conceptually a different thing, hence it having a separate key command.

This is exactly why its annoying for the Dynamics to stay and get pushed down…

If you select the note I think you can press Tab and it will cycle through all the objects that are at that rhythmic position.

You can also quickly toggle the system track via the shortcut Alt+T (or via the jump bar, by typing “system track” and hitting Return).

If you do as Dan suggested and create a key command for changing the dynamic intensity, this will never happen because you’ll just edit the dynamic which is already there.