Why does my Step Modulator appear like this in the Macro page?

Don’t pay attention to the knobs or anything other than the actual step modulator window. I would expect to see 16/32 blue bars here. I’ve tried shuffling up and down in the order to move it front/back but that doesn’t make a difference.

EDIT: This topic was how to merge macros which as you can see I’ve now managed to work out.

Ok, 1 step forward 2 backward.

I manually typed Mono Step Modulator.step1 in the TemplateParameter section and the blue bars appeared. Success!

However, despite entering this down to step4 only two bars have appeared. Extending the right red border only stretches the bar width, it doesn’t show additional bars. Furthermore, these bars don’t reflect those in the Mono Step Modulator so I don’t think they’re connected.

I’ll continue to play around myself but any tips would be welcome.

If you scroll down the template parameters there is a parameter called “Steps”.

Connect this to your step modulator. This determines how many steps are used.
Step Modulator (Template) - HALion Macro Page - Steinberg Developer Help

1 Like

Woohoo!!! Sorted.

image