Why is Cubase recording (MIDI) during precount?

I’m doing MIDI recording and it starts recording when the precount starts, and the biggest problem is that the event it creates doesn’t start at the cursor (I just recorded a bunch of parts for a song, but I can’t click and drag them to rearrange them because they’re all screwed up and don’t match up).

Is there a way to change this behavior so it starts recording at the cursor?


This is to make sure, that the very first note will be recorded, even if you press the note before the real start.

And you are right, MIDI parts are snapped to the Bars, in default settings You can disable this in Preferences > Record > MIDI > Snap MIDI Parts to bars. If this is disabled, the MIDI parts start exactly at the position, where the cursor was, when you pressed Record.

Thanks Martin. That makes sense.

I wish Cubase would treat the events just like the recording process, so that if you start recording with a count-in and hit notes before the cursor, it will expand the beginning of the event to include those notes, but the event will still snap to the beginning of the event as determined by the cursor when you started recording. Is it possible to configure Cubase to do that?


You are right, with the pre-count enabled, it’s always snapped to the bars. Even if the Preferences is disabled. But this make sense, to me. The Click has to be somehow alligned to the grid.