Why is imported MIDI added *after* existing bars in project?

In MIDI Import Options, I’ve selected “Overwrite all track contents when importing into existing flow/player,” and I’m importing this MIDI into the existing flow (Flow 1). But after importing, the MIDI is placed after the existing bars in the project, instead of where it belongs (according to the existing bar numbers). Why? And how do I correct this?

OK. I did this three times—with unwanted results—before posting here. After posting, I tried a fourth time, and now the midi is in the correct place. I’m not aware that I changed anything in the MIDI Import Options window. (In fact, I had the “Use Track Memory” option enabled, which is supposed to use the same options as those previously used.)

So, I’m stumped. But this fourth import is now correct. Go figure.

The only thing I can think of is that perhaps the MIDI data you are importing starts with a bunch of rests, so that the imported music ends up being offset by the duration of those rests.