Why is my midi automatically being doubled?

Everytime I record midi information, it also records these long legato notes, and way far down the line it seems to have doubled the midi information. Has anyone experienced this?

I attached a screenshot of what I am experiencing. Thanks!
Untitled.jpg

What type of MIDI controller (keyboard?) are you using?

If it is a keyboard connected via MIDI (5-pin) cables, then you will need to to find a setting in the keyboard to turn “Local” off. If this is the case, as a test you could temporarily disconnect the cable out from Cubase to the MIDI IN on your keyboard. If you can then record without error (but naturally not hear back) then that will be the problem. Alternately, if you don’t want to go disconnecting cables, you could disable MIDI Thru in Preferences.

I am actually using a usb midi keyboard.

My first guess then would be that either it’s faulty, or its driver is not working properly. You’ll have to diagnose the problem by a process of elimination – try the keyboard on a different computer using different software, or try a different keyboard with your Cubase installation.

Make sure that the MIDI / Instrument Track you’re recording into to only one input port and not, “All MIDI Inputs.” Sometimes I forget this and it records from USB and MIDI from my KB.

If that’s not doing it, suggest seeing if there are updated drivers for your MIDI KB.

It would help if ppadru2 would tell us the type of USB MIDI keyboard it is (make, model?).

Some MIDI controllers have multiple “ports” available. Mine has USB MIDI A and USB MIDI B. If your keyboard has this feature, then either edit the settings in the MIDI controller so it only sends on one of the ports OR in Cubase select ONLY one MIDI port as the input to the track (as opposed to “all MIDI Inputs”, as someone already mentioned.)
HTH
J.L.