Why is player's name displayed in ALL CAPS?

I’ve imported a MIDI file with about 8 tracks. One track (in my sequencer) was named “MIDI Lead Vocal,” because I played in the notes manually while listening to a sung performance. Dorico imported the track names from the MIDI file—but for this one track only, Dorico insists upon spelling the name in all caps. So, it was displayed as “MIDI LEAD VOCAL.”

So, I went to Setup > Players, found the “Edit names…” command, and changed it to “Lead Vocal” (just like that—with initial caps only). Well, Dorico indeed changed the name, but once again, it insists upon capitalizing it, even though I absolutely did NOT do so when I renamed the player. So, Dorico is displaying this player as “LEAD VOCAL” (in all caps). None of the other players’ names is being displayed this way. Just this one track. Why?

How do I get Dorico to capitalize this player’s name in exactly the manner I’m indicating?!

Look at the Staff Labels page of Engraving Options, where you will find an option that tells Dorico to show staff labels for vocal instruments in capitals.