Why isn't my .vst3 showing up? +Question about UIDescription editor

I want to build a template project in C++ for my other projects in VS. For the purpose I copied most preferences from the “again” example. To test whether the template works I copied all the source/header files as well as the references, just to be sure. Finally I debugged the project and it ran without errors.

Setup:

However, the created .vst3 won’t show up in the DAW (Reaper), probably crashing on scan. Is there any explanation for why this could be happening? (Note that I removed the original again.vst3 from the scan directory).

I also have a secondary issue, in Reaper when the “Open UIDescription editor” option is selected on one of the example projects, the program crashes.

Have you checked that running your plug-in thru the vstvalidator is successful ?

Do you get the same crash in the editorhost example ?

Regarding Reaper - the crash on Open UI Description Editor is a known problem; I asked about it on their Forum last year:

https://forum.cockos.com/showthread.php?t=180636

I’ve looked at it and it happens in vst3editor.cpp involving the popup menu. The crash is on the line in VST3Editor::onMouseDown( ), which is line 913 for VSTGUI4.3:

VST3EditorInternal::addCOptionMenuEntriesToIContextMenu (this, controllerMenu, contextMenu);

It looks like the contextMenu is bogus/corrupt, but I have not gone any deeper into it.

Reaper is the only DAW I’ve used that exhibits this problem, and it happens on both Win and MacOS.

  • Will

They both produced the same “dll does not export the required ‘GetPluginFactory’ function” error. I fixed it now by including a definition:

LIBRARY
EXPORTS
	GetPluginFactory @1

Still not sure how the original worked without.

I am not quite sure if I got you right. But in case you use cmake for project generation this line exports GetPluginFactory already:

https://github.com/steinbergmedia/vst3_cmake/blob/master/modules/AddVST3Library.cmake#L49

René