Why isn't the Project Tempo written into new audio files?

When you record your on an Audio Track you get a new file. Why isn’t the tempo of the song written as default to the file instead of “???” which you find in the Pool? If I record at 120 BPM say a guitar there’s no reason the tempo should be anything else until I purposely change it, is there?

For example I have now a project with 15 audio files where 4 is set to the Project Tempo, 2 is set to some random tempo and the rest are marked with “???” and I haven’t touched the tempo in any of them. You can argue that it works as is but it doesn’t.

I want to test what it sounds like a little faster like 130 BPM instead or something like that. I can’t just stay in the Project Window, change the tempo and everything is good. No, I have to open the Pool, maybe sort the files to have them lined up, select all the files without tempo plus one with the tempo, click in the one with the right tempo and hit enter and all files now have the right tempo. I also need to know about this in the first place to remedy the behavior in the project window and the mess in the monitors with audio files drifting all over the place.

Anyways … is someone else suffering from this? I’ve never seen it work in any other way over multiple versions of Cubase over multiple computers. It is a mild annoyance so I probably have had better things to do than ask before now. It also is intermittently popping up like there is no set rule for how and when the tempo is written to the file?

After all that typing I bet there is a preference setting taking care of all this ? :laughing:

I also wish the timestamp of the files in the pool included hours and minutes like YY-MM-DD HH:MM:SS instead of just YY-MM-DD. If you sort your files that way you’d have them line up chronologically better instead of e.g. alphabetically. Maybe the timestamp works as it should but I can’t see it with just dates? Very minor thing …