Why no snap to grid in Sample Editor using range tool?

Any ideas about the thinking behind this?

Why doesn’t it follow snap on/off status?

Hi,

Because there is no Snap to Grid in this editor at all.

There is, maybe it’s called audio editor.

But there’s definitely a snap grid on/off button there.

Hi,

Sorry, I was reading Sampler Editor.

Abd yes, I can confirm, the Range Tool doesn’t Snap.

Totally agree. It makes NO SENSE to not be able to use Snap to Grid in the Sample Editor when using the Range Tool. Shouldn’t it function the same way as in the main Project window? The workaround in the Sample Editor is to make a loop location selection with Snap enabled, then go to Edit/Select/In Loop. I made a Key Command Ctrl + Cmd + L. Steinberg, can you PLEASE address this issue so we can use the Range Tool in the Sample Editor with Snap???