Why this is shown?

I see this In my score I know I can hide it, But why it’s showing here? What is it mean. Is it me that a make it from the first place?
I’m sorry little confuse
Screenshot_1.jpg

It’s telling you that you have an irregular bar of some description. We’d need to see more context (i.e. the music before and after the portion you’ve clipped) or preferably the project itself to provide further assistance.

Here is the file
I try to delete it but nothing happens. Rather than hide this there must be a way to delete it?
Writing in the wall_LH.rar (522 KB)

It looks like you re-input barlines at those positions - if you select the barline at the end of the system before each signpost, you’ll see the signpost is selected too. Delete the barline, rather than the signpost. This doesn’t remove the barline but rather your “barline override” - you should see a single barline remains after you delete the override. In general, you shouldn’t need to input single barlines unless you want one in the middle of a bar or at various points in an open time signature.

That’s work Thank you :open_mouth: :astonished:

I have other problem also. I can’t input note to my last bar. Like if the score is look or something
Writing in the wall_LH.rar (522 KB)
Screenshot_2.jpg

You have rest mode turned on. Type comma (,) to turn it off.

I try it, But it didnt work

I don’t know what language your keyboard is, but if you are seeing a grey rest next to the caret, that means you have rest mode turned on. Look over at the left panel, find the rest, and click it to turn it off.

If you roll your mouse over it, you should see a keytip telling you what the shortcut is on your keyboard. On mine, it’s a comma.

This is useful, I got one of those once and didn’t know why either.

What can cause an irregular bar? One as Lillie found is a barline override.

Barline overrides or hidden time signatures. You might see them in imported XML particularly.

Thanks Lillie. I brought up that project - unfortunately can’t share due to project copyright - but it is the barline because when I select it the flag selects also. Don’t know how this happened, something goofy as I was composing no doubt. Anyhow deleting the barline just deletes the barline and messes up the bars. Any ideas?



Edit: Actually it selects/highlights if I select any of the following barlines. Curious.

Edit^2: NEvermind. You have to select and delete the barline that the flag is on, I selected a following one (which also highlights the flag). Fixed!

Make sure you’re not deleting it in Engrave mode (which creates a bracket and barline change). That shouldn’t happen really, unless you’re deleting twice: first deleting the override barline, then deleting the underlying barline. Dorico automatically shows barlines as appropriate for the time signature, but you can still delete those. Where there’s a signpost, you’re deleting the override.

If subsequent barlines are connected, then it could be a hidden time signature that you input maybe for note grouping reasons? (Well that’s true for barline overrides, as really they are an implicit time signature change - as you can see if you select the signpost, the Time Signatures group is available in the Properties panel.)

Yeah thanks I added an edit up above. What threw me off is that if you select any of the following barlines it highlights the flag. I was in Write mode figuring that in Engrave wouldn’t be good, anyhow selecting the exact barline that the flag is on does the trick.