Why tokens don't work in music text?

I wanted to write B-flat using the flat symbol in music text (Cmd+X). But the token doesn’t work here. Why is that?

Tokens don’t work in text objects, only in text frames. To show accidental glyphs in text objects, you can copy the glyph (the glyph itself, not the unicode) from e.g. here and apply the Music Text character style to it using the text editor options.

Thanks for your reply. But that doesn’t seem to work either. This is the result:

I find it almost ridiculous that it isn’t possible to easily insert a simple music glyph inside just any text inside Dorico. It is a music notation software and creates so many complexities for entering music glyphs inside text? So it seems I need to create a text frame, so I can write B-flat as text inside music. But I want its position attached to the music.

That might be down to the font (i.e. if it doesn’t support these characters). Alternatively, here’s a text object (using Academico, the default font in Dorico) into which I’ve inserted a flat glyph just from the emoji/symbols viewer character viewer on mac:


Or another idea/option, a chord symbol with “maj” shown (which you can change in Engrave>Engraving Options>Chord Symbols):


Thanks for your reply. Somehow the pasting doesn’t work with me, also not after having changed to Academico font. But using a chord symbol and then changing the font style of chord symbols works very well. After that, I need to add the text “major” and in Engraving mode aline the two.

Have you tried adding the flat glyph directly from your computer rather than copying and pasting? I’m on Mac, and went to the “Emoji and Symbols” keyboard viewer, searched for “flat”, and when the cursor was active in the text object, double-clicked the flat in the keyboard viewer to enter it. Worked nice and easily.

Thanks, that works. In Academico font it shows correct, but in another font there Dorico creates space before and after the symbol that can be changed.
Bflat Academico

I haven’t double-checked this myself right now, but if you’re using a different font for the surrounding text, you should still be able to apply the Music Font character style to just the flat glyph.

Yes indeed, I tried it now too. Thanks a lot for your help! :slightly_smiling_face:

1 Like

You’re welcome! Just looking again at your latest screenshots, if you want the scale text indication to be further to the left than the first notes on the staff (and you’ve got 3.5.10) there’s now an “Align with system start” property that automatically positions the text with the systemic barline, if its rhythmic position is at the beginning of the system.

Thanks! I’ll try that out.