Why won't Step Input (MIDI Editor) start at cursor?

Is there some magical preference that can make the step input start at the cursor? EVERYTIME it starts at the beginning of the project, requiring me to pull the blue line towards current start. It is extremely annoying and puts me off from using it in the first place.

It’s an invaluable tool crippled by this obscure behavior. Any tips on how to handle it?

Click on the spot after you turn on step input. And, there’s a key command that will move the insert cursor to the beginning of a part. It’s called ‘Move insert cursor to part start’

But yes, this is a frequently reiterated FR.

This has been buggin me lately as well, thanks for the tip.

I’d like to add: is there some magical key command that can make the step input jump to the cursor? Or even better: follow (be ‘glued to’) the cursor? I am using a controller with a jog wheel, and that is perfect for quickly positioning the cursor to the desired location. Now if only the ‘blue line’ (step input) would follow…

On a side note: I don’t understand why most controllers lack a jog wheel, nothing beats it for scrolling to a location quickly and precisely…

Regards,

Paul

Necro Bump. I made my . button become this ‘Move insert cursor to part start’ for step recording. As Paul091 asked years ago, do we know if there is a setting for the blue line to follow cursor?