Wierd Timeline Ruler Behavior

Hi there …

Over the last three or four projects, I’ve come across a random weird (but interesting) behavior with the time line ruler. I thought it would be best to bring it to your attention.

The behavior occurs in the edit window and so far only when using the Spectrum Editor.

Specifically, what occurs is that the ruler in the lower (Spectrum Editor display) section of the display suddenly shows an incorrect time line.

For example: the track is 4min 55 sec in total length. The overall display in the upper window confirms this. But suddenly, the ruler in the lower section shows a time frame that is completely wrong: like 6min 53 sec … a field that is outside the overall time line for the track. The upper section of the display remains correct.

I cannot reproduce the error. It happens completely at random and infrequently.

When it occurs, the track will only play from the start … not a surprise since the cursor ‘thinks’ its at, say, 6min 53 in a 4min 55 sec track, and it’s no longer possible to continue to edit. It is possible to save successfully and if you reopen the track it seems to work OK. WaveLab does not crash.

I am uploading a screen shot that better illustrates the issue.
Screen Shot_Timeline.jpg

Good description, thanks. But I haven’t seen that so far and have little cue. If you even happen to grasp what triggers this…


Can this be memory related, I mean if making a lot of editing/undo
maybe memory cache is involved here !?

regards S-EH


You’ll be the first to know.

Another time-related thing, which I haven’t yet had the opportunity to try and isolate: I was editing in the montage, and when I overlapped two clips, the auto-generated fade-out in the first clip was longer than the overlap - the fade-in in the other clip was OK. I haven’t yet determined whether this is just a display anomaly or an actual one.

I’ll be looking again this evening (WL isn’t my day work).


Hi PG …

You asked me to advise if I was able to advise more on this.

It’s been a while and this timeline thing would not show its head no matter
how much I edited (mastering is my job by the way).

However, it has just happened again and I have more to report. As promised, here are the details:

Again, it only seems to occur when working within the Spectrum Editor.

I suspect it be triggered by using the cursor to ‘zoom out’: that is, ‘pushing’ the
cursor against the time line ruler to zoom out horizontally. I was looking at the screen and saw
the ruler values change as I was doing this.

I also experienced the event when positioning the cursor for replay of an edit (that is, not using
the pre-roll function), but in this case the timeline display did not immediately change as it did
when ‘pushing’ the cursor against the timeline ruler.

Another thing: after the error has presented itself, if you change to the waveform view
the error is initially preserved. That is to say, the ruler displays the same incorrect
timeline values that were present in the Spectrum view when the waveform screen initially displays.

But then, if you use the Ctrl+arrow down command to zoom out horizontally to display the
whole waveform, the error is immediately corrected (meaning that the timeline ruler then displays the
correct values).

Changing back to the spectrum then displays a corrected view also.

Similarly, if you remain in the Spectrum display and use the Ctrl+arrow down command to zoom out
horizontally to display the whole waveform, the error is immediately corrected.

Either way, it is then possible to continue as though nothing has happened. This includes resuming edits in the
Spectrum view.

Nothing is lost and WaveLab never crashes.

It is still not possible to reproduce the error again at this point.

I deliberately did not save the track until after I tried all these things. To allay any doubt it
saved fine. I also closed it and re-opened the saved file to double check all was OK: it was.

Also, it does not appear to have anything to do with the amount of unsaved work on the file (data in memory etc).

I save ‘early and often’ … a legacy of doing post in ProTools … and the last time it occurred there was but
one edit performed since the last save. And, this machine is almost new and has 4gig of good quality RAM which
we’ve tested (to help you exclude this from your considerations).

I keep detailed settings notes from session to session so I was also able to compare what I was doing
to the last time it occurred. The only thing in common were plugs, but these same plugs had been used
on most jobs since it last occurred with no ill effect.

And, of course, when it last occurred I was simply unable to reproduce the error at the time, as
was this case on this occasion.

To allay any doubt, this has never occurred when working within the waveform display … no matter how intensive the editing may be.

It’s interesting behavior.

Thanks for your accurate post. I have corrected a zoom issue that would occur around 1:8 ratio. That might be the problem, I don’t know (would happen also in waveform view). I will keep an eye on it anyway.

Thanks PG …

I will keep an eye on the zoom ratio next time the behavior occurs. I never thought to look at that … but then I’m not a programmer. It could well be the common denominator.

I will keep you informed.

Things to keep an eye on, if this happens:

  • what is the exact time offset?
  • does it happen only if the time scroller is near the end?

Will do PG!

PG …

As requested, here is some additional information.

I am currently working on an album and the issue surfaced twice. I’ll call these ‘events’.

First time:

Zoom x 1:7

Pre Roll 0s Post Roll 0s

Cursor position on overview pane on event: 3 mn 26 s 818 ms

Overall actual file length: 5 mn 24 s 460 ms

On event, the ‘file length’ becomes: 7 mn 34 s 258 ms

When I hit ‘end’ to verify the apparent offset, the error corrected!

Second time:

I was unable to calculate the exact timeline offset on this occasion: I used a different approach and
unfortunately it corrected itself before I was able to ‘see’ the end of the timeline.

However, the different approach may offer some extra helpful information.

The approach centered on a marker I had positioned for another purpose at 3 m 36 s 500 ms. This was
coincidentally in view at the time the event occurred.

On the event, the marker instantly ‘moved’ out of screen … to where it thought it should
be: 3 m 36 s 500 ms … and I was looking instead at a a region around 7 m 18 s 500 ms. I want to be clear
that this was not the exact spot the marker ‘had been’ … just very near it. The top pane overall view remained
correct as usual … showing the correct cursor position (that is, mismatched with that in the spectrum timeline

I wondered what what occur if I went to the marker position. I was thinking this might help me accurately
calculate the offset. So, I hit ‘4’ … the go to previous marker command … and on doing this was surprised
when the screen immediately redrew and everything was immediately corrected: that is, the timeline was redrawn and redisplayed everything in correct position … including the marker … coinciding once again with the overall view in the pane above it.

As a consequence of this unexpected correction, I regret there was no opportunity to note any further
information such as zoom and incorrect end of file details.

As before, nothing was lost, WL did not crash or hang, and the file could be saved and reopened
without hesitation or incident.

On neither occasion did the event occur as the cursor was toward the end of the file.

As with previous occasions, I am simply unable to reproduce the error. On the last event I tried for at least
10 m without success.

I make the observation that through all of this, WL never stops ‘feeling solid’. By this I mean, if you
have been using music software for a long time, there are certain configurations and combinations that
somehow just don’t ‘feel’ solid and reliable. WL 7 to me feels ‘rock solid’. And what’s interesting to me is that when something like this arises, the ‘feel’ of WL does not alter. Everything remains ‘snappy’. This suggests it’s something simple.

I hope this observation makes some sense to you.

Good luck!