Win: Steinberg Auto Power Profile Gets Stuck On

I have noticed that when exit Cubase 6, sometimes it doesn’t change the power profile back to “Balanced” and instead when I check it says “Steinberg Auto Power.” Seems a bit dangerous to leave a modern PC with the minimum processor state set to 100%…?

ah, it is Cubase 6 that messes up my power profiles sigh - a had all my settings trimmed to perfection, this morning everything was back to default.

Can I tell Cubase to let my power profiles be? In preferences maybe?

// Lazze

Devices
Device setup
VST audio System
Then Uncheck
Activate Steinberg Audio Power Scheeme

I want it to be on when Cubase is running for best performance.

But it’s supposed to go back to the old settings when you exit.

how is it dangerous?


I’m not on C6 yet but in C5 I notice that when I close cubase it sets my power back to ‘balanced’ even though I always had it set on high performance… it has screwed me up a few times already when it unexpectedly went into standby or hibernate when I left it doing something unrelated to cubase, so I stopped using the steinberg power plan because I always like to leave it on high power. I’ve been doing it this way since Vista.

I don’t know for sure, but I suspect these new processors are built to spin down a bit when the PC is idle. Forcing it to stay at 100% might decrease your time to failure due to heat.

And more heat = more noise!

Well, it’s just a power scheme, isn’t it? You’re only telling the PC to save power after such and such time by doing so and so (screen off, HD to sleep etc.). You’re not forcing the CPU to process random data to stay at 100% or anything…

Luck, Arjan

Then what does ‘Minimum Processor State’ mean?

The Steinberg profile has minimum set to 100%. Balanced has it set to 5%.

C6 messed up my power profiles the FIRST time. When I reset, and restarted C6 - it all worked 100%. It choose my old profile with my settings applied(I use some special settings for my SSD:s)

So after the initial failure that ended in a BSOD(in power scheme) - it now works just fine.

// Lazze

For me it works sometimes and fails others. You don’t really realize unless you check the power control panel.

Well, I must say after some more research, there is a little more to it than just a power scheme. It’s about the processor’s ‘throttle’ functionality; being able to change processor speed (clock frequency) to the demand placed upon it. 100% means the CPU is at maximum clock frequency and anything lower means a percentage of that frequency. Apparently the Steinberg profile requires the processor to remain at the maximum speed, even with ‘nothing to do’, so to speak. Compare it with a car’s idle rpm being at 4000 while in neutral… Everything you want to know about it from Microsoft: http://download.microsoft.com/download/3/0/2/3027D574-C433-412A-A8B6-5E0A75D5B237/ProcPowerMgmtWin7.docx

Luck, Arjan

Exactly. And more speed means more heat and earlier failure. I want the highest performance I can get while Cubase is running. But my CPU was at 100% unintentionally all night long because the profile didn’t properly reset to ‘balanced’. Not a huge deal but it should be fixed.

Why do I leave my PC on at night? Automated backup. Defrag. Antivirus scans. Etc. All run overnight.

Yes, ofcourse the power profile should be returned to what it was by Cubase, when shutting down. At the same time, I think if your concern is earlier failure, shutting down the PC each night will do lots more in that department. I mean - these tasks you mention can easily be done in 15 minutes each morning. Let the PC start up automatically at a certain time and save hours of idle heat dissipation - even at 5% CPU speed…

Luck, Arjan

Hmmm… I’ve never seen a backup or a defrag get done that fast personally…

I don’t ALWAYS leave my PC on overnight, but it do it enough that I’d be sad to learn my CPU was pegged at 100% the whole time.

Let’s just fix the problem of not setting the power profile back reliably and all will be fine :wink:

Hi there

FYI Cubase power scheme doesn’t make your CPU run at 100% load. Just open task manager (right click on task bar) and check performance or Resource monitor.

I’ve also experienced that when closing Cubase, the Power Plan sometimes gets set to Balanced even though I had it set to High Performance before I opened Cubase. A workaround is to manually adjust Balanced to what you really want, and then use Balanced as your main Power Plan… but this should obviosly be fixed.

However, if you’re running a quad-core processor, it’s important to disable core-parking in Windows 7:
http://forum.cakewalk.com/tm.aspx?m=1852473&mpage=1

Task manager shows CPU utilization. What Steinberg Auto Power does is set your CPU clock speed to 100%. Modern CPUs can spin down unused cores. Balanced lets them go down to 5% of their max, saving power and probably giving your CPU a longer life.

good idea!

thanks

Now that’s interesting. Not that I have problems yet, but why not disable something that may pose a problem…

Luck, Arjan