Win10 Dorico Pro 2.1.0 update re-install problem

Hi fellow Doricans,

I am having problems installing / re-installing Dorico Pro 2.1.10 in Windows 10.
I tried to install the update over Dorico Pro 2 but it kept saying: “Steinberg Dorico 2 not installed.”, even though it was and I could run it.
After searching the forum, I saw a post recommending a full de-install / re-install which I did, however it didn’t work.
This is what happens:

  • I run “Dorico_2.1.10_Installer_win.exe”
  • some extracting takes place
  • the “Setup” program pops-up
  • there is a brief message “please wait while the installation program is initializing”
  • the Setup program crashes and disappears from the screen *
  • When doing the above with the Windows Task manager running, the “Setup” programs shows as “not responding” then “suspended” before it crashes.

I have downloaded the latest installer via the “Steinberg Download Assistant” application.
I have tried to run the installer as Admin.
No other programs are running.
I have disabled my Anti-virus program just in case.
I have also updated to the latest “eLicenser Control Center”.
My USB dongle shows “Dorico Pro 2” as installed.
My version of Win 10 is up to date.
I have plenty of spare disk space.
I have re-booted my machine several times after each update/attempt to install.

Any thoughts or suggestions?


Sorry you’re having these problems, Rudi. Can you make sure you’ve run all of the latest Windows updates, and in particular the latest version of the .NET Framework, then try again?

Hi Daniel, thanks for your help. I have re-run Windows update and it tells me my PC is up to date.
I have checked the version of the NET. Framework and the latest version I have for Win 86x and Win 64 is:


It’s a very odd problem… all my other pieces of software, including Cubase 9.5 Pro are updating fine.

Can you try running the installer from the command line using msiexec, telling it to produce a verbose log file, and then attach the resulting log file for us?

I couldn’t run “Dorico_2.1.10_Installer_win.exe” through msiexec, so I ran the “Dorico2.msi” file directly and it worked perfectly.
I re-ran the full installer and the updater afterwards and both run perfectly now.
There must have been something corrupt on my system… if it happens again I’ll use msiexec.

Thanks for your help, and a great piece of sofware!

Great, I’m really glad you’re up and running now!