Win7 64bit not finding Midex 8

Just bought a Midex 8x8 off Ebay. Having trouble installing it on my Win 7 64 bit machine. The first time I installed the 64 bit software it asked me to switch on the midex and then the driver seemed to install ok. It then said to reboot, which I did and since then it has not worked. It just doesn’t appear as a device.

Things I’ve tried:

  1. Reinstall drivers.
  2. Install 32 bit drivers on my laptop. That works so the Midex seems ok.
  3. Used “add device” in “devices and printers”. Hangs at add device screen.
  4. Forced driver install using “hdwwiz.exe”. Driver installs but has yellow triangle in “device manager”.
  5. Tried connecting to different usb ports. Midex is still not seen.
  6. Connected psu to midex and then tried connecting to different usb ports.
  7. Tried connecting to powered usb hub.

Does anyone have any other ideas that I could try?
Has anyone had the same problem on Win 7 64 bit?

Sorry to hear and no, mate. Just thought I’d pitch in with “mine works”, only so that you’ll know that it does work on W7x64.

Are you using the new driver, only recently (unofficially) released?

Strange behaviour, mine installed just fine as well on W7 64 using the unofficial driver package.

Thanks for the replies. I completely uninstalled the driver, disconnected several other usb devices then reinstalled using a different usb port. Seems to be working now.