WIN7: ASIO overloads well before i7 980x is maxed

I’m working on a project that is pretty heavily loaded. It’s full of instances of Kontakt on instrument tracks, one instance of omnisphere with 6 instruments loaded, an instance of Trillian with 2, and an instance of RMX. There are also plenty of VSTs (1st and 3rd party) on busses and tracks.

As far up as 384 samples latency, I’m getting occasional ASIO red along with clicks and distortion. The overruns occur at times when there are lots of simultaneous note-ons.

When I bring up the windows task manager, I see that the CPU doesn’t get past 50% but one of the 12 ‘virtual’ cores is close to 80% while the others are under 30%. The project isn’t being balanced evenly.

Thoughts?

You may want to try loading separate VSTi’s, instead of separate instances of instruments in one VSTi. I believe if you do it the latter way, it uses all the instruments in one memory space, provided for that VSTi. If you load separate VSTi’s though, each will have it’s own memory space.

This is only an assumption on my part, but I think it is reasonably accurate.

So let’s say you have Kontakt with 10 instruments loaded into that VSTi. Split it up, create another Kontakt VSTi, and put 5 of the instruments in each instance. I have found much better stability and less of those unusual midi artifacts by doing it this way.

All of my Kontakt instruments are in separate VSTis on instrument tracks, and these make up the majority of the patches in this project. My last project was all Spectrasonics instruments (the ones that are set up as single-instance, multiple-instrument configs) and it never had this issue.

Hmm… I wonder if I have it backwards? I don’t use a lot of VSTi’s for my project, and I typically set them up separate, like described. I do remember trying it with one VSTi instrument instance, and separate midi channels assigned to that instance. But I seem to remember having problems with that.

In any case, there are a couple of options you can try. You might want to duplicate the project itself, and try a few different VSTi configs to see if there is any improvement.

Also, I noticed you have 10Gigs of ram? Which is kind of unusual. What kind of memory do you have and what are the timings?

HP shipped in that config. Here’s what the sales receipt said:

10GB DDR3-1066MHz SDRAM [4 DIMMs]

It looks like there is something that creates DPC latency in your system. Check out this tool: http://www.thesycon.de/deu/latency_check.shtml

In my case, my problem was a utility that I was using to monitor the motherboard and CPU temperatures. The web site has some good troubleshooting tips on how to find out where the problem resides.

Let me know how it goes.

–Stefanos.

I did the latency checker in the “30 day return” period of the PC and it was incredbly low. No DPC issues a far as I can tell.

Now I did swap video cards for a fanless one that has 512mb instead of 1GB and turn on Aero (which actually seemed to improve ASIO performance), so I could recheck. But I’m pretty certain this is some other issue.

if it’s an i7 980 then the ram should be in sets of 3 as the x58 chipset is designed for tri channel ram. If you’ve got 4 sticks then something’s seriously astray.

You should have either 3 slots filled or all 6, doesn’t matter what size you use as long as either 3 or 6 slots are used.

if you’re using memory hungry plugins/and/or processes then this might be your problem.

MC

I’m not an expert on this but Kontact is a multi-voiced instrument. It is more efficient to load it in the VST rack where you can access it with individual midi tracks playing different sounds. One instance of Kontact can play many voices/instruments. This should be far more efficient from an ASIO perspective.

Hi Norbury,

The i7 processor can use either dual-channel (sticks in even multiples i.e. 2,4,8,16 gb) or tri-channel (sticks in multiples of three i.e. 3, 6, 9) I have an i7 with 8gb on two sticks. Unless the 980 is different and then I stand corrected.

Does not operating a Tri Channel memory controller in dual mode severely restrict the memory bandwidth?

Now I did swap video cards for a fanless one that has 512mb instead of 1GB and turn on Aero

Try turning Aero off before anything else.
I also thought for a while it might be OK leaving it on with a powerful PC but once I started having dropouts in heavy projects turning it off turned out to be the easy & immediate solution.

One Kontakt with a dozen instruments loaded will surely be more cpu efficient than a dozen Kontakts…why not try switching to this methodology.

exactly, and memory bandwidth is what you want when running samplers.

Also,are you doing your bounces in real time? if you’re streaming from disk, which Kontakt does then you can’t really export faster than real time due to the fact you can’t speed up the disk streaming aspect.

The default Faster than real time renders only work for mathematical calculations like summing and applying FX ,nonstreaming V.I’s etc


MC


MC

So… I found the opposite to be true, interestingly. I started without Aero. I just assumed it was the right thing to do to turn it off. And I had ASIO glitches and pops while doing things like scrolling the project window during playback. I actually had a thread about this specifically. Asking what I should do about these glitches and pops.

Someone replied saying that Aero moves the processing of the on-screen graphics to the GPU from the CPU. Which I didn’t realize. I switched to Aero and the ASIO load DROPPED and the glitches simply disappeared.

Here’s the thread: http://www.steinberg.net/forum/viewtopic.php?f=81&t=3362

I think that might be true with a single-core CPU, but with a modern CPU, wouldn’t having separate instances allow Cubase to balance them across the cores? I suppose Kontakt might be better at managing streaming if it had all the instruments loaded in one rack. I could certainly do this. Just wondering if it wouldn’t make the load on one CPU the bottleneck.

I had no idea about this. Strange HP would send me a PC with a performance-degrading option.

My problem is not during Export (which I do not do during realtime, but has worked perfectly), it’s just during playback and recording. I have mitigated it by increasing the latency to 384 samples on my ProFire… but that’s sad because I’m running at 40% CPU utilization.

what’s your fire wire chipset? sounds like a FW issue to me. Do you have a PCI(e) soundcard you can try?

I’m running an i7 920 with 12 gigs of ram and 2x MR816’s and run at 64 samples most of the time,using EW PLay and Kontakt too absolutely no problems at all.


MC

Wouldn’t FireWire issues show all the time regardless of project content?

I think 80% on one core and 30% on the others is where the problem is — I also agree that decreasing the instances of plugins will help, but surely it’s only by decreasing the load.
My thoughts are that there is a vsti causing problems, maybe conflicting with another vsti, I may be wrong but what I would do is backup Project and then remove one Vst (all instances) then check how even the load is over the cores then replace it and remove another and see if there is a culprit, I’d start with third party ones but leave Kontakt until last and do steinberg ones before Kontakt.
Other thoughts are you may have reached the sound card drivers limit. But then I think why uneven across cores and come back to above idea.

I think your PC must have 4x 2Gb sticks plus 2Gb on the graphics card.
I have never seen a 3Gb stick and the other option of 2X 4Gb plus 2X 1GB = 10 Gb with a 980X just seems wrong, but is probably right.
Having bought a PC with the daddy of all processors I would definitely want Tri channel memory unless there were stability issues, I wonder if HP found configuration problems on the platform and had to settle for dual channel, might be worth asking them especially if you want to reconfigure, it might just mean 1 stick of 4Gb depending how they got to 10 Gb.

More Geek orientated is audio issues with core parking but that really is for the hardware section :smiley:
Hope this helps.

I’m certain I have 10GB of real RAM. I will have to check the bios to see how the RAM is organized.

The video card was a 1GB ATI which i swapped for a 512MB fanless nvidia.

A strange config then, unless I ve got the maths wrong, 2x 4Gb + 2x1Gb rather than 3 x 4Gb with that processor is a strange decision unless there is an underlying reason, ask Hp if you can do an upgrade to see what they say.