Windows 10 1803 AUDIO DROPOUT TIP - AMD Radeon

USB and audiostuttering with AMD Radeon - Windows 10

I’d like to share this . I think i finally found why USB audio stutters happen especially with AMD games graphics cards and Windows 10 64bit 1803. In my case i was forced to use the default Microsoft GPU drivers, but then i had occasional graphics related crashes with Cubase among others. Maybe worth a sticky. So i reinstalled the latest AMD Radeon drivers. Again stuttering, appearing after a while, especially after playing f.i. Youtube videos etc.

As such it seemed to me that some buffer gradually overloads, so i searched across various gaming sites and found this solution, and it seems to work:

(Quote) Performance Tip for AMD GPU users for stutter/lag

Microstuttering and laggy playback is an all-too-known issue with any gaming system, and some good people on the net have come up with a possible issue with AMD installs:

AMD installs a service to write to the Event Log called ATIeRecord.
If your event logs are huge and/or fragmented, then this service will record while you are gaming,
and the recording lag from bad fragmented system files will hammer your performance with lags and stutters.

The fix?

Disable the service.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Atierecord]

Set to “1” by default which enables it. Disable it by setting it to "0" …

NOTE: If you install, re-install or update the AMD Radeon drivers it is set back to ‘1’ !!
PS, there seems to be a similar thing with NVDIA GPU cards, maybe there’s some related setting.

Does it also do that if you install the driver only?

The AMD installer has no options to install ‘just’ the driver without all the unnecessary crap.

PS i found a way to install just the bare GPU drivers, without the gaming ballox, GPU audio and more; first uninstall (i used an AMD cleanup tool). Reboot and then manually select the appropriate driver via Device Manager, by locating it yourself. in my case i copied it first from C:\AMD\Packages\Drivers\Radeon-Adrenalin-18.5.1-c0328911-win10-64bit-180522_drvWHQL, an installer folder.

Important: You’ll still have to disable the Atierecord registry entry after that. Seems stable now regarding audio stutter, and my graphics issues with the standard Microsoft drivers seems over. I did use an older driver in my case; my AMD GPU card is 4 years old now. -F

Thank you so much i think im on the right way now to solve my problem. I do experience alot of audio dropouts especially when opening Frequency Plugin or anything that shows Spectrum curves. Audio dropouts stop once i tab out of cubase. Using windows graphics driver seems to be the only working way so far. I installed radeon driver (without software) and changed the reg key. but still i have dropouts :frowning:

Do you by now have any further information on that topic?