Windows 10 1803 Spring April update issues/solutions

Updated to 1803. No issues apart from the usual “ELCC run as Admin”.

is there any news about Windows 10 build 1803, compatibility?

So far it works well (for me, at least), apart from the issues mentioned by me and others in this thread. Some plugins may need reauthorization after the update.
MW

Here’s the latest (May 9th) from Steinberg: Windows 10 Redstone 4 compatibility

The latest Windows 10 update also known as Spring Creators Update is now available. As far as we can tell this update does not affect compatibility with Steinberg software and hardware. However, we’ll be back with you shortly with an official recommendation for the new update of Microsoft’s Windows 10 operating system

Updated. Not issues so far.

There appear to be some issues with the latest Windows 10 update to 1803, KB4103721
https://www.techrepublic.com/article/windows-10-users-should-wait-to-install-the-latest-update-its-bricking-some-pcs/

Windows 10 users may want to hold off on updating their PCs: The first cumulative patch for the Windows 10 April 2018 update is causing some PCs to enter a cycle of failed boots.

The bug in update KB4103721 was first reported by Microsoft forum users, only some of whom were affected. Microsoft added a note to the KB4103721 patch notes stating “select devices with Intel SSD 600p Series or Intel SSD Pro 6000p Series may repeatedly enter a UEFI screen after restart or stop working.”

I updated my Windows 10 Pro x64 today to version 1803 … when i trying to start Cubase 9.5 Pro this window is appear … It trying to start some installation and stuck on Initialing: VST Audio System. And nothing happens …

my setup:
Windows 10 Pro x64
Cubase 9.5.21 Pro
Steingerg UR22MK2
Nektar Panorama p6
bug.png

I think it trying to install for some reason audio drivers for my Steingerg UR22MK2… I manually downloaded UR22mkII_Firmware_Updater_V104_win from Steinberg.net… Trying to install it, but nothing happens… instalation is stuck like when i starting Cubase…

https://helpcenter.steinberg.de/hc/en-us/articles/115001588410-Windows-10-Fall-Creators-TOOLS-for-UR-Preparing-to-install-

Thanks… I fixed my problem… I uninstalled Yamaha Steinberg USB Driver, downloaded latest from https://www.steinberg.net/en/support/downloads_hardware/yamaha_steinberg_usb_driver.html , reboot Window… and problem is gone

I have to sort this after every Win 10 update.

First run Maintenance in Admin mode on the ELicenser then start Cubase in safe mode disabling Preferences, then re- assign the ASIO to the UR22. Once done, just close and restart in normal way. I have found that by using this method, I don’t have to touch the drivers.

Very interesting, Parrotspain! Thanks for posting.

Thanks Windows
After the update of Windows Pro 10, I cannot longer start Cubase Pro 9.5.21
Why are Windows always such an asholes?

Now Cubase stops after startup and want to install something, it seems the soundcard have to be installed or updated again but it wont work to update with UR28M_firmware_V211.exe (printscreen TOOLS_for_UR28M_V216_Win.png) it takes ages and do not work,
or with the TOOLS_for_UR28M_V216_Win/setup.exe (printscreen Win 10 update - Cubase 9521.png)
The TOOLS_for_UR28M_V216_Win/setup.exe leaves a blank dialog box with no chance to use the checkboxes.

So what can I do, should I Roll back the Windows installation and hope that this will do the trick or something else?

ALl the best!
Pete

Please have a look above at
https://www.steinberg.net/forums/viewtopic.php?p=742388#p742388
and/or
https://www.steinberg.net/forums/viewtopic.php?p=742387#p742387

Great!
Thanks, this link helped me out!
https://www.steinberg.net/en/support/downloads_hardware/yamaha_steinberg_usb_driver.html

Everything is up and running again!
//Pete

I updated to 1803 and had to go back to 1709 immediately. (I had some time between projects, so I took the chance)

On the 1803 build, I had the usual clip and audio dropouts that had been going on periodically since windows 10 / cubase 8.
Cubase did open up fine, and even closing a session or the program went well (on 1709 i have to always end task from task manager). But performance of VST/CPU was very poor.

To be fair, windows build 1709 gave me the same trouble in the beginning. And rollback is very smooth, if you stay within the 30 days.
Since my system is running fine in current config, I’ll leave it as is for the time being.

If you have performance issues after upgrade check carefully your windows power management settings and stuff like usb selective suspend and usb device disabling to save power.

Hi
Yes, in fact, I have noticed it. Will check it Thanks!

hi… I have cubase 9.5 for long time.
today updated my windows and suddenly my elicenser didnt work well so i removed it and reinstall it…
now cubase opens and when i hit play it dont respond anymore.
i dont know what to do… please help me

What type of audio interface (“soundcard”) do you have? Can you uninstall the drivers for it, and re-install them?