Windows 10 1809 now available

Has anyone installed in their Cubase machine?
I’ve tried it on non-DAW machines and it installed and works fine but …

1809 is installed here (about three hours ago) and I have been doing some simple editing on several projects without issue. No new recordings yet though.

Regards :sunglasses:

Thanks for the information Prock.

Is this update related to Cubase’s performance with multi-core-thread CPUs? Please, let me know :slight_smile:

Day 2 now, and updated both PC and laptop.
Update requires a large amount of free space (like 15gb) or more approx. More than previous updates I think

Cubase required uninstall of eLicencer software (as well I had to uninstall the driver from Device Manager), then reinstall. I tried without doing the Devices manager thing and it was a no go. elicenser installed but wouldn’t see any connected devices.


Ilok, required uninstall and reinstall.

I too, had to uninstall the eLicense application and driver. Reinstalled.
ILok seems ok without any change. It’s running version 3.x??.

Interesting… my update went without issue and I did not have to uninstall and install anything.
So… day 2 for me too and I have been editing existing projects for hours without issue. Also, I did record a few audio and instrument tracks for test purposes with no issues at all.
FWIW… my computer and Cubase “feels” snappier to me. Cool! :wink:

Regards. :sunglasses:

I had a pop up first time I started Cubase, elc needs to be started with admin rights. But it continued loading without issues.
Next time I launched Cubase all was normal.
No problems with iLok plugins.
Need to test some some of my rarely used plugins, but no issues so far.

No problem with Cubase or eLicenser, but as usual problem with Korg MIDI drivers, to see my Korg synths in Cubase.
Had to uninstall them and install again.

Hmm, my elicenser is fairly old now, so is my ilok 2.

Installed 1809 yesterday and did a live show last night using Cubase to run my backing track. Had to run the eLicenser app once but that was it. Everything else ran faultlessly.

Just realize I’m at 1809 already two weeks( maybe less)

Didn’t see any changes in cubase performance, nothing reinstall. Everything works ok.
Cubase 9.5.30
UR44 lastest drivers & firmware

Balls of steel, this one :mrgreen:

There are not as many chances under the hood on this one compared to the last update.
There are some nice user level changes, like the clipboard cloud thing. The dark themed explorer and the enhanced snipping tool are also welcome changes.
There are no changes to anything that would improve unique plugin count or process scheduling (MMCSS count).

Hey guys, thanks for taking the plunge and sharing your experiences.

As you may know, Steinberg is theoretically testing it right now – https://helpcenter.steinberg.de/hc/en-us/articles/360001124240-Windows-10-Redstone-5-Steinberg-Product-Compatibility

But it’s always great to hear the first-hand experience with stuff like this. I’m holding back on my main DAW for now… but I might try it out on a different machine. My guess is that like others have already mentioned, there’s nothing under the hood that should mess up Cubase, so I’m thinking it’s probably going to be fine.

Also, I bet this is – in part – the reason why the Cubase 9.5.40 update has been postponed. At this point, I’m guessing that they’re holding it back to test it with 1809. Who knows though?

I had eLicenser fun with the 1809 W 10 update too. Something odd and USB related perhaps?

There are almost always some fun with copy protections after a update.
For Steinberg products it can for the most part be solved by starting the eLicenser as Admin and running a Maintenance.
Sometimes a newer version has to be downloaded and installed.
That is completely normal behavior and don’t expect that to change anytime soon.
That’s the nature of copy protections being very low level and Windows 10 updates being pretty much a new OS install.

I heard some rumours a while back that this year’s Windows 10 update might fix some issues with audio and hyperthreading. Just wondered if anyone adventurous who has had problems with dropouts on multicore systems could post their experiences following the new update? I had to disable many CPU features in BIOS as a workaround which feels like deliberately hobbling my PC just to get Cubase to work properly, so it’ll be nice to know if the new Windows update would allow me to use it to its full potential. If no-one has, I might have a play around next week and report back what I find…

Just a heads up, this update consolidates KB4100347 which breaks all overclock and non-standard settings for Broadwell E processors.

This can affect even a non-overclocked set up in so far as linking core speeds and fixing core speeds is concerned
Plenty on the web about it, Just search KB4100347 and Broardwell E

There is no work round other than not updating.
Hippo

Well, it looks like Microsoft just pulled the update for now, as it investigates reports of some users who have had some of their personal files deleted during the update – https://www.engadget.com/2018/10/06/windows-10-october-update-delete-pulled/

Looks like Microsoft now wants to compete with Apple for worst update issues! Well done, Microsoft, the bar has been set low by Apple, but if you work at it, you might beat them!