Windows 10 and sound

I am using this on forced upgrade of windows 10, i have two laptops

  1. Asus core i7 8gb ram, nvidea, … blah blah works fine
  2. new lenovo core i7 (faster processor) intel graphics, 8gb ram, etc.

Asus no problem, record multitrack audio, playback no problem
lenovo , record is working 80% of the time, playback, only 1 , 2 or 3 tracks play simultaneous, the tracks that don’t play wont play, it is random, i can mute some of the playing tracks to see if the others play , nope, shutdown reload then track 2, 4, 5 play …

copy the project to the asus, all plays fine, i also hear some small clicks sometimes, thinking it is my asio hardware, but i use this same box on the asus

i am above recommendations on specs
tried in device setup all settings, etc , also tried compatibility mode because on windows 8.1 it was working

so i am thinking this might be a error with .wmv why,
because i can import the .wmv audio in adobe audition, all 4 or 5 tracks and they play, export each track as .flac

then start new cubase project, import all .flac into the new project (like a mastering template) and all playback fine.

most of the time…
i cannot figure out what is the difference, and why this behavior

someone suggested get a newer up to date asio compliant sound cards Usb , but i think this is software, or os specific

please help thanks

Hi and welcome,

I would recommend you to check your Lenovo system via LatencyMon utility.

Thanks says It is suitable - i suspect Latency also but what is interfering ?


CONCLUSION


Your system seems to have difficulty handling real-time audio and other tasks. You may experience drop outs, clicks or pops due to buffer underruns. One problem may be related to power management, disable CPU throttling settings in Control Panel and BIOS setup. Check for BIOS updates.
LatencyMon has been analyzing your system for 0:00:34 (h:mm:ss) on all processors.

\


SYSTEM INFORMATION


Computer name: OG8
OS version: Windows 8 , 6.2, build: 9200 (x64)
Hardware: 20268, LENOVO, Cherry 3A Touch
CPU: GenuineIntel Intel® Core™ i7-4500U CPU @ 1.80GHz
Logical processors: 4
Processor groups: 1
RAM: 8115 MB total

\


CPU SPEED


Reported CPU speed: 2394.0 MHz
Measured CPU speed: 738.0 MHz (approx.)

Note: reported execution times may be calculated based on a fixed reported CPU speed. Disable variable speed settings like Intel Speed Step and AMD Cool N Quiet in the BIOS setup for more accurate results.

\


MEASURED INTERRUPT TO USER PROCESS LATENCIES


The interrupt to process latency reflects the measured interval that a usermode process needed to respond to a hardware request from the moment the interrupt service routine started execution. This includes the scheduling and execution of a DPC routine, the signaling of an event and the waking up of a usermode thread from an idle wait state in response to that event.

Highest measured interrupt to process latency (µs): 1502.349747
Average measured interrupt to process latency (µs): 21.163294

Highest measured interrupt to DPC latency (µs): 1465.571472
Average measured interrupt to DPC latency (µs): 6.900387

\


REPORTED ISRs


Interrupt service routines are routines installed by the OS and device drivers that execute in response to a hardware interrupt signal.

Highest ISR routine execution time (µs): 82.771930
Driver with highest ISR routine execution time: ACPI.sys - ACPI Driver for NT, Microsoft Corporation

Highest reported total ISR routine time (%): 0.248079
Driver with highest ISR total time: USBPORT.SYS - USB 1.1 & 2.0 Port Driver, Microsoft Corporation

Total time spent in ISRs (%) 0.251030

ISR count (execution time <250 µs): 29094
ISR count (execution time 250-500 µs): 0
ISR count (execution time 500-999 µs): 0
ISR count (execution time 1000-1999 µs): 0
ISR count (execution time 2000-3999 µs): 0
ISR count (execution time >=4000 µs): 0

\


REPORTED DPCs


DPC routines are part of the interrupt servicing dispatch mechanism and disable the possibility for a process to utilize the CPU while it is interrupted until the DPC has finished execution.

Highest DPC routine execution time (µs): 588.275689
Driver with highest DPC routine execution time: ndis.sys - Network Driver Interface Specification (NDIS), Microsoft Corporation

Highest reported total DPC routine time (%): 2.170081
Driver with highest DPC total execution time: USBPORT.SYS - USB 1.1 & 2.0 Port Driver, Microsoft Corporation

Total time spent in DPCs (%) 4.920874

DPC count (execution time <250 µs): 218301
DPC count (execution time 250-500 µs): 0
DPC count (execution time 500-999 µs): 1391
DPC count (execution time 1000-1999 µs): 0
DPC count (execution time 2000-3999 µs): 0
DPC count (execution time >=4000 µs): 0

\


REPORTED HARD PAGEFAULTS


Hard pagefaults are events that get triggered by making use of virtual memory that is not resident in RAM but backed by a memory mapped file on disk. The process of resolving the hard pagefault requires reading in the memory from disk while the process is interrupted and blocked from execution.

NOTE: some processes were hit by hard pagefaults. If these were programs producing audio, they are likely to interrupt the audio stream resulting in dropouts, clicks and pops. Check the Processes tab to see which programs were hit.

Process with highest pagefault count: latmon.exe

Total number of hard pagefaults 35
Hard pagefault count of hardest hit process: 13
Highest hard pagefault resolution time (µs): 110773.195489
Total time spent in hard pagefaults (%): 0.185175
Number of processes hit: 5

\


PER CPU DATA


CPU 0 Interrupt cycle time (s): 5.527790
CPU 0 ISR highest execution time (µs): 43.157895
CPU 0 ISR total execution time (s): 0.338389
CPU 0 ISR count: 28638
CPU 0 DPC highest execution time (µs): 373.002506
CPU 0 DPC total execution time (s): 4.703421
CPU 0 DPC count: 196243


CPU 1 Interrupt cycle time (s): 0.861948
CPU 1 ISR highest execution time (µs): 82.771930
CPU 1 ISR total execution time (s): 0.001759
CPU 1 ISR count: 159
CPU 1 DPC highest execution time (µs): 588.275689
CPU 1 DPC total execution time (s): 0.256373
CPU 1 DPC count: 4616


CPU 2 Interrupt cycle time (s): 1.958924
CPU 2 ISR highest execution time (µs): 43.834586
CPU 2 ISR total execution time (s): 0.001836
CPU 2 ISR count: 247
CPU 2 DPC highest execution time (µs): 515.228070
CPU 2 DPC total execution time (s): 1.430055
CPU 2 DPC count: 15644


CPU 3 Interrupt cycle time (s): 0.833877
CPU 3 ISR highest execution time (µs): 35.679198
CPU 3 ISR total execution time (s): 0.00020
CPU 3 ISR count: 50
CPU 3 DPC highest execution time (µs): 418.110276
CPU 3 DPC total execution time (s): 0.317893
CPU 3 DPC count: 3189


This is my system specs on Lenovo

Lenovo U330 TouchTech Specs
DESCRIPTION LENOVO U330 TOUCH
Processor
Intel® Core™ i7-4500U Processor


Display / Resolution

13.3" Full high-definition 250 nits (1920 x 1080) display, 16:9 widescreen with 10-point multi-touch
Graphics
Integrated Intel® graphics
Memory
Up to 8GB DDR3L-1600Mhz [1 SODIMM slots (1 x 4GB / 1 x 8GB)]
Storage
Up to 1TB HDD with 16GB SSD

Dimensions
322 x 224 x 4.5 ~ 19 mm (12.67" x 8.81" x 0.17" ~ 0.74")
Integrated Communications
WiFi connectivity with Bluetooth® 4.0
Sound
Stereo speakers with Dolby® Home Theatre® v4
audio certification
Battery
45 Wh
10 hours on Windows 8 Idle @ 150 Nits
6 hours full HD playback
Weight (Net)
1.70 kg (3.74 lbs)
Camera
Integrated 1.0 MP camera
Connectors
2 x USB 2.0
1 x USB 3.0
2-in-1card-reader (SD / MMC)
2-in-1 audio jack (headphone and mic)
HDMI-out

Hi,

Sorry, I’m not experienced Windows user. So I would recommend to do this (what the result recommend):
disable CPU throttling settings in Control Panel and BIOS setup. Check for BIOS updates.

My Asus is Intel Core i7-3517U CPU @ 1.90Ghz 2.40 Ghz,
Ram 8.GB
64 bit
Nvidea Graphics GeForce GT 740M

On the asus
CPU Speed is 2395 MHz

Highest measured interrupt to process latency (µs): 688
Average measured interrupt to process latency (µs): 4.

Highest measured interrupt to DPC latency (µs): 667
Average measured interrupt to DPC latency (µs): 1.5


Not sure what to compare … or what is interfering…

I turned off bluetooth on the Lenovo to make sure it was not interferring. I have about the same applications installed on both. The Lenovo is my new backup laptop, i want to make sure i can do the same things.


Installed Cubase ele 8 trial because it has more asio options same result.
copy the files from my lenovo to asus, unplug usb asio from lenovo into asus everything plays fine.

Possibly I create a new user on Lenovo, shut down every service i dont need and app running, to get to the minimal and see if that helps ?

Although this appears to be latency, I tried something else

I created a new project, (mastering)
imported each audio file from the project (that i recorded into)
same problem

but …
i take the audio files, into adobe audition, save as .flac or .mp3 not .wmv which CB creates
import them into individual audio tracks, playback is fine

maybe it is a permission problem with the .wmv or codec problem ?

next…
i tried new user, all unnecc services and programs not running did not work

next next…
i will convert the .flac back to .wmv from audition, and try to import into a new project and see if i can play back multiple tracks.

maybe someone has a similar problem and fixed it

ok this test failed

the original .wav files from the projects / audio directory play fine in any media player
so i took them into adobe audition, (actually the .flac files I created for a test) converted to .wav

then new project, mastering, three tracks,
imported each new .wav into it, same problem. (i choose copy files into the /audio )
one track had no sound, just like the recorded version.

but if i import the .flac all three play together fine,

.flac is actually higher quality,

this must be a .wav file problem with cubase on this system,

UPDATE FIXED

I was using a high speed USB drive to save and run my projects too, when i copied all the files to the local harddrive
all the problems went away.

latest usb 3.0 highest speed available, but it must of caused latency issues.