Windows 10: audio dropouts on multi-core CPU setups

I have managed to improve my ASIO performance significantly on a 6 cores CPU so I thought I could share my settings in case it could help someone.

A lot of problems came from some Intel and Win10 features that are always trying down-clock the CPU speed to save power consumption, which is totally an ASIO killer. This was causing my ASIO meter to be very unstable, and was causing ASIO drop outs on heavy load.

CPU is a i7-6850K base clock at 3.6Ghz with a Turbo Boost at 3.8Ghz and a Turbo Max at 4.0Ghz. Max memory speed at 2400Mhz.

The key for me was to figure out how to “lock” the CPU at 4.0Ghz (Turbo Boost Max), all the time, which is the maximum speed of the CPU, without having Win10 or BIOS feature to down-clock the speed of the CPU.

So here all the BIOS settings I had to manually change to make sure the CPU stays at it’s full potential, all the time:

1-Extreme Memory Profile (X.M.P) at Profile 1, to have my RAM running at 2400Mhz instead of the default 2133Mhz
2-Intel Turbo Boost Technology: Enabled, all Default
3-Intel Turbo Boost MAX Technology 3.0: Enabled. (This is what makes my CPU running at the max 4.0Ghz.)
4-Hyper Threading: Enabled. Seems to be ok for me

Now to prevents the CPU to be down clocked or down powered:
5-CPU Enhanced Halt (C1E): Disabled
6-C3 State Support: Disabled
7-C6/C7 State Support: Disabled
8-CPU EIST Function (Enhanced Intel® Speed Step Technology): Disabled
9-In Windows, make sure to use the High Performance Power Plan. In advanced properties, make sure to have all Processor Power settings at 100%.

Now, after a reboot, my CPU is locked 4.0Ghz all the time, with my RAM running at 2400Mhz.

My ASIO meter is now barely going over 20%, even under heavy load instead of moving back and forth and causing ASIO drop outs.

Hope it helps someone.
Nick

So… I’ve switched to x299 i7820x lately (previously riding x99 and i5820k) and… turning HT off was the worst case scenario for me. And believe me, it comes from someone who invests heavy money into a DAW rig and spots the difference. First run with audioengine props file was smooth… second one not so much so I’ve removed nvidia drivers (from nvidia not from microsoft update) - i love my gtx card (1060) but since 5XX series they tend to have problem with latency spikes and eco/power saving mode. Just google it :wink:

I’ve updated my Cubase to 9.5 and everything went smooth. I brought back HT, and there is a huge difference for me (in speed and responsiveness), while running Windows 10 Pro. But still… only 14 logical cores :confused: Sucker am I? :smiling_imp:

Anyway… I hold back with updating Meltdown/Spectre patches (come on, hack me if u can for a next 23 days) and I’m little dissapointed about Cubase performance barrier… yeah, you can blame Microsoft too but I think, Steinbergs’s team relies too much on Windows „not so known or documented” restrictions (membah stupid aero mode requirement?).

Just my 5 cents…

Try modifying that audioengine properties file to set 28 threads instead of 14. I did this on my 7940X and it is using all of my logical cores without a hiccup. I think Steinberg got their wires crossed on that thing, it sets the total number of Cubase threads (not how many cores to run 2 threads on). When I used the default, only 14 logical cores were used and I knew that meant only half of my physical cores because it was the first half instead of every other one. Maybe without having that file at all Cubase will try to spawn 2 threads for every logical core it finds, but whatever value gets configured in that file sets a strict thread count limit.

Side note: I sold my Xeon box and switched to 7940X specifically because of this limitation. No reason to be able to expand to 24 physical/48 logical cores in the future when Win 10 maxes out at 28 logical cores for DAW. I really hope Microsoft gets this sorted out now that we have enthusiast chips on the market that can exceed this limit.

omniphonix…how do you modifying audioengine? Could you please describe for me how to do it…i also have a 7820x and would like to know how to use my system to the max in cubase.

@st33l

this means file “audioengine.properties” you can found /download from there to install inside given steinberg paths
https://helpcenter.steinberg.de/hc/en-us/articles/115000535804-Windows-10-audio-dropouts-on-multi-core-CPU-setups

Default setting of this file by steinberg:

audioengine.threads.max=14

I’ve recently built out the following system:

Proc: Intel Core i9-7900X Skylake X 10-Core
Motherboard: ASROCK X299 Taichi
Ram: CORSAIR Vengeance LPX 32GB (4 x 8GB) DDR4 2666
Cooler: Noctua NH-D15
OS Drive: SAMSUNG 960 PRO M.2 512GB NVMe
Media Drive: SAMSUNG 960 PRO M.2 1TB NVMe
Samples Drive: SAMSUNG 960 PRO M.2 2TB NVMe
Video Card: Gigabyte GeForce GT 1030 2GB Silent Low Profile
Screen: LG - 34UC79G-B 34.0" 2560x1080
Case: be quiet! PURE BASE 600 - Black
Power Supply: be quiet! - Dark Power Pro 11 650W 80+ Platinum
Software: Cubase Pro 9.5, Native Instruments Komplete 11 Ultimate
Audio Interface: RME Fireface UFX+

On initial setup, the Cubase 9.5 demo song was playing with no issues and plenty of headroom down to a buffer of 32 samples. Recording, however, was not working down to 32 samples. Cracks, dropouts, etc. I didn’t change anything else (HT still on) and dropped in the audioengine.properties file with no changes. With that change, recording with a 32 sample buffer was fine. A 64 sample buffer didn’t bother me and I did a jam session with Guitar Rig for over an hour without a single hiccup.

This is going to be a great system, I think!

Guys look @ this https://sendvid.com/3i5g2pf7
The key is never go under 128 samples with HT On.
128-256 Buffer + HT on + Asioguard = best performance.
HT needs minimum 128 Buffer or you get a popcorn machine :wink:

The link doesnt work for me :frowning:

Mine works best with: 128-256 Buffer + HT OFF + ASIOGuard High
But still not great overall performance from what I am used to on this very same machine.

The key is to experiment with your specific set up. It’s not so polarized as many make it out to be.

How much did this machine cost?

Here’s the parts list: https://pcpartpicker.com/user/cyberkrunk/saved/T8NPsY

Thats not including the 2200 audio interface!!

Hi. I tried to repeat your benchmark. In my case, the processors are loaded only by 65%. If I turn off the Hyperthreading, then the processors are loaded by almost 100 percent. But more than 33 Halions do not pull in both cases.

Ok nice :+1: to me this looks like the Asio load need more clock speed, the limit is Cubase in this case.
Try it with VEP on same machine your Workstation is much more powerful.

This can’t be upvoted enough, thanks Nick you shurely saved my day and the performance on two mashines : :smiley:

I’m now running 18 synths 64smp buffersize UR44 on Intel Core i7-7800X Skylake-X clocked to 4.5Ghz. I never go above 33% load and I have 2.3ms latency. My system are now rock steady.

This is what I find too. At a buffer of 64 or 32, performance improves when Hyperthreading is disabled but at 128 or above, it’s better with Hyperthreading on. I’m running an AMD 1920x (24 logical cores). Cubase can fully load all 24 cores, given the right type of project.

Any official news on this?

Is this still a Thing? I mean it was announced almost a year ago :frowning: is this even possible to fix by Steinberg/Microsoft?

It appears that Windows Pro for Workstations will provide new, kernel-level optimisations for low latency applications.

https://www.theregister.co.uk/2018/02/15/microsoft_windows_10_workstation/

https://blogs.windows.com/business/2017/08/10/microsoft-announces-windows-10-pro-workstations/#2GGpDlCofiCMEUoz.97

The new, relevant power plan is currently available via the Windows insider programme.

Is Steinberg looking into this? Can we have an update on whether Windows Pro for Workstations will affect the performance of Cubase Pro?

Thank you

Something else for consideration…

https://www.facebook.com/notes/vb-audio-software/finally-windows-10-could-support-audio/1646244165445117/