Windows 10: audio dropouts on multi-core CPU setups

The only way you can / could get lower latency then 128 is by setting hypertrading to OFF in the bios…

There are a couple of tweeks in the BIOS that might help. I got these from support:

Intel SpeedStep
Turbo Mode
CPU C-States

Make sure those three are disabled. I think the C-States on did the most for me.

Also, limiting the number of cores used by Cubase can help. See this article, but support showed me a registry edit which is the better way of doing it. Ask them as I am not sure how they worked out the number.

https://helpcenter.steinberg.de/hc/en-us/articles/115000535804-Windows-10-audio-dropouts-on-multi-core-CPU-setups

Finally, there is a problem with Dropbox, of all things. One of the dropbox DLLs can cause issues. Just turn off dropbox sync while working, if you have it.

None of this is a perfect solution, but it may get you out of the mud!

It is a real mix, to be honest. MS have introduced some issues with Windows 10 and the way it is handling audio. PLEASE don’t ask me for details - someone pointed me to a MS dev discussion that was SO over my head!!!

However, it is something that is messing things up, not just Cubase, and they are looking at how it is fixed. Maybe in Redstone 4 (April update)? I haven’t updated yet, so I have no idea.

In my case with a 14-core i9, turning of hyperthreading made no difference. Disabling C-States did, however

I could also work on my system with a latency of 32 samples, but not with the same amount of real-time workload (VSTi’s/PlugIns).

The overall performance in Cubase becomes significantly worse if i deactivate HT.
Besides, using Soundblaster or a professional Audio-Interface can make a big difference in terms of Audio-Performance.

I am getting very mixed results at the moment. I am using a Clarett 8pre Thunderbolt. So, for instance, I can load a Hollywood Orchestra with 20+ instances of PLay and that works well.

But heavy latency devices like Ozone 8 cause me headaches. And I am getting lagging if I have too many windows open.

I can’t get down to 32 - as soon as I open an audio channel to input, it goes nuts.

So, a very confused picture at the moment.

Actually 64 samples should be more than low enough for most usecases anyway. In my case only the UAD-PlugIns can’t work below 64 samples.

The Soundblaster Xfi is a good card and goes to 1ms and runs like a charm. Most cases the CPU load and use of many VSTi/VST plugins will run the processorload over multicore’s. The Soundblaster Driver is as steasy as can be, a good test is Wavelab and a very very low latency setting, it works. But like all are struggling because they want and Processorload/VSTi/VST and Low Latency. The middle is about 8ms of latency, where on a modern machine i have plenty speed left and no probs. There was a post that a users found 8ms not enough… and because of his classical music education and use of protools was debunking Cubase for not having a lower latency. So i quess it is more up to the user. I say 8ms latency and a speedy system is what is a good middle road. Also expensive soundcards can have BAD drivers. And USB is not as fast as you think. Dropping an internal card might save you headroom for latency en speed… For instance many users have a Focusrite USB Audio, well the drivers where so bad i dropped it straight back to the SB and sticked with that. The Drivers are sometimes more important then the audio divice…

I have had similar problems for different reasons. Aside from music, I also do voiceovers. Hearing even the tiniest delay is really offputting.

However, this is not a major problem with interfaces like the Focusrite because they have internal DSP and a good mix/monitoring system.

I did try the Presonus Quantum with Cubase. That has no internal mix, and despite their boasts of zero latency, it was just impossible. Used with Studio One, it was better, and just about passable, but not comfortable like direct monitoring.

I dream of the day when this is all as easy as it was with a good old analogue multi-track! haha

With voiceovers a latency of 8ms is ok.
As long as you dont hear double voices.
Most of the time this is caused by direct input and delay of latency output.

I do voiceover over video all the time with 8ms of delay.
As long i dont have double sound of the voice (it is ok).

Is there any update from Microsoft on this yet? I’m running 1803, and I think it’s still an issue. I will petition them heavily, and in person if I need to (I’m a Seattle resident). This is really unacceptable for a modern OS, and seems quite arbitrary and blindingly stupid on their part, if I’m being blunt (I am). I would really, really like to see this issue resolved ASAP. I will do anything I can from my end to help them see the light. Even if it means getting musician friends to come and picket the Redmond campus. Only half joking.

Nope! Last update of Windows 10 does not change this situation. I sstill have dropouts.

The reason i bought a brand new PC was to have a better machine for making music. I saved for several monthes and was so happy when i had bought everything, built it and installed cubase and everything i need for music making. Then it shows no better performance at all than my old one. All my happiness of the new PC went oposite. I cant understand why its so difficult to fix this issue because it wasent there in previous version of windows. MS, take a step back and look at win7. Its a pity if i need to install an older OS when i buying a newer PC

The i7 7820x you have listed in your Sig. is not affected by the reduced mmcss threads of Win10.
There is something else that bottlenecks your performance.

@peakee…isnt it like this, i copy from the start of the thread here…"Cubase is the “process”, windows reserves 4 MMCSS threads, leaving 28, Cubase schedules two MMCSS threads per CPU core (real or logical), 28 divided by 2 is…14 logical cores or?..my cpu have 16 logical 8 real cores and i have HT enabled should be 16 logical cores and should be affected…or?..have i missunderstand it?

Hi Fabio-can you please clarify something for me:

The article says a way to deal with the issue is to “Limit the amount of cores used by the application’s engine”. It then mentions two ways. It doesn’t mention turning off hyperthreading within Cubase itself.

If I’m using a 7900x CPU (10 core, 20 threads) and turn off hyperthreading in Cubase, does that then mean that I have taken care of this issue?

This geting to be a very very very very very very very very very very very very … Long Posting!

:smiley: :slight_smile: :wink: :frowning: :astonished: :open_mouth: :confused: :sunglasses: :unamused: :smiling_imp: :imp: :cry: :blush: :stuck_out_tongue: :angry: :laughing: :exclamation: :question: :bulb: :arrow_right: :neutral_face: :mrgreen: :nerd: :ugeek:

Hello,

you can turn off multi-processing, but you can’t turn off hyper-threading from Cubase, that’s a hardware feature.

Besides the properties file and turning off HT in the BIOS / UEFI, there is a third option that can’t be published in the article - user interested in that should contact support directly.
There is nothing to be done on Mac, though (but if you use a PC with such a config, just drop me a line).

Kind regards,

Hello,

Are you reffering to registry trick mentioned by Pete Brown on Microsoft forum? Looks like a ball is in Steinberg’s corner now.

How should I contact support directly? Polish distributor doesn’t give a … about this issue and support. Tried twice to reach em.

Hello,

yes, I was talking about the registry entry - I have just replied to such a question relied from Polish support.

For anyone who contacts support or distributors about this, please mention the exact model of CPU you employ.