Windows 10 can't recognize UR242

I have a problem with UR242 on Win10. After installation of software from CD, as it was written in manual, DI wasn’t recognized by Device Manager (code 1) and Power LED was flashing. But it was still named as “Steinberg UR242”, under “Unknown” category.

I uninstalled whole software and remove drivers/device from Device Manager. I installed latest USB drivers after I update firmware of DI. I done the update on different computer with Win7, no problem there whatsoever. But on my 10, system still doesn’t recognize the DI. I’ve done several reinstallations of drivers, with reboots, no difference. Power LED still flashes. I try to fix this for 2 days and now I’m out of ideas.

After restart with working DI it stops flashing, but it’s still unrecognizable. In device manager DI is named as ‘usb composite device’, code 18. Yet, when I try to reinstall drivers by manager, pointing directly to ‘C:\Program Files (x86)\Yamaha\Yamaha Steinberg USB Driver’ or to device list, it says that “Windows find driver software for your device but encountered an error while. One of the installers for this device cannot perform the installation at this time”

Changing USB port doesn’t do much. I tried troubleshooting of Hardware and Devices in Control Panel, I deleted drivers through Device Manager repeatedly, my Windows Update is set to automatic and I used this: Troubleshoot common USB problems - Microsoft Support.

Yamaha Steinberg USB Driver software doesn’t see DI, Cubase the same

I realize that it’s not a problem of DI or driver but it’s my system fault. DI worked perfectly under other Win10. I have a clue what it might be, but it gonna takes time. I gonna put solution to the problem after some time, because I’ve seen similar problems before.

My system won’t allow to install drivers, I dunno why, but I figured that out when I connect newly purchased midi controller, which too was unknown to computer.
Solution I find is a little harsh, but it worked. I create USB Recovery Drive and use it to Recover form a drive. But you need to remember that you gonna lost ALL your data, even on additional hard drives. So it’s a nuclear solution.
You may try to go back to restore point or use image of a system, I didn’t have one so a have no other option left.
Nevertheless, it worked.

End of topic.