Windows 7 Service Pack 1 Audio/CPU problems

Installed bunch of W7 (about 80 or something) updates 2 days ago and Service Pack 1. (Usually DAW isnt hooked up to Web, only about once a year for updates) and started having audio drop out problems.

Yesterday was working on a project and about every 5 minutes or so a 5 second audio drop out occurs and right when it occurs Cubase CPU meters spikes to red for about a second.



my setup:
Windows 7 Ultimate x64
Cubase 6.5.1 x64
Presonus StudioLive 16.4.2 thru TI based FW adapter using Legacy FW driver

Sounds like something is running in the background… probably some update service or similar.
If you haven´t optimized your computer, then check this ->

http://www.native-instruments.com/knowledge/questions/847/Windows+7+Tuning+Tips+for+Audio+Processing

and

this -> http://www.blackviper.com/service-configurations/black-vipers-windows-7-service-pack-1-service-configurations/

I don’t wanna do complete re-insatll yet (usually it takes up to a week to reinstall all software)

I double checked if all unnecessary Services are disabled according to BlackViper.
No AntiVirus, No Windows Defender, All web/updates etc services disabled.

I Also noticed that the drop out happens after I do “Save” in cubase (I do save very often) and aproximately after 16-18 seconds after I click “Save” or “CTRL+S” the drop out occurs.

And When the project gets pretty big with alota patches load in vstis.

LatencyMon gave me “Your System seems to have a problem… One Problem maybe related to Power Management, disable CPU throttling in Control Panel and BIOS”

I Checked Settings in CP the CPU cooling is set to “Active” and in BIOS everything is Disabled except A250 or something, don’t really remember, but the CPU BIOS settins are according to DAW recommended settings from Steinberg or Presonus Website


I didn’t try Updating CPU or BIOS drivers yet.

edit:
This is a weird, I ran the LatencyMon again, the dropout occurs after doing “Save” but LatencyMon doesn’t detect it, says “Your System appears to be suitable for handling real-time…”
Also, the very bottome bar called “Highest reported hard pagefault resolution time” is all the way in the red zone, whole bar full!

I updated BIOS. Still same problem

Same Problem in 32bit Cubase, happens with All projects too.

Also Updated Jmicron Driver and Chipset. No luck. happens at higher buffers also (1024 and above)

This is the screenshot from the main page LatencyMon:

http://i806.photobucket.com/albums/yy345/vadim9687/TS1.jpg

and the results:


CONCLUSION


Your system appears to be having trouble handling real-time audio and other tasks. You are likely to experience buffer underruns appearing as drop outs, clicks or pops. One problem may be related to power management, disable CPU throttling settings in Control Panel and BIOS setup. Check for BIOS updates.
LatencyMon has been analyzing your system for 4:30:45 (h:mm:ss) on all processors in the system.

\


SYSTEM INFORMATION


Computer name: VM-PC
OS version: Windows 7 Service Pack 1, 6.1, build: 7601 (x64)
CPU: GenuineIntel Intel® Core™ i7 CPU 920 @ 2.67GHz
Logical processors: 4
Processor groups: 1
RAM: 8182 MB total

\


CPU SPEED


Reported CPU speed: 2672.0 MHz
Measured CPU speed: 2989.0 MHz (approx.)

Note: reported execution times may be calculated based on a fixed reported CPU speed. Disable variable speed settings like Intel Speed Step and AMD Cool N Quiet in the BIOS setup for more accurate results.

\


MEASURED KERNEL TIMER LATENCIES


Highest measured kernel timer latency (µs): 2242.403299

\


MEASURED SMIs AND CPU STALLS


Highest measured SMI, IPI or CPU stall (µs) 0.766241

\


REPORTED DPCs


Highest DPC routine execution time (µs): 286.393713
Driver with highest DPC routine execution time: nvlddmkm.sys - NVIDIA Windows Kernel Mode Driver, Version 295.73 , NVIDIA Corporation

Highest reported total DPC routine time (%): 1.777342
Driver with highest DPC total execution time: ohci1394.sys - 1394 OpenHCI Port Driver, Microsoft Corporation

Total time spent in DPCs (%) 2.614944

DPC count (execution time <250 µs): 212565903
DPC count (execution time 250-500 µs): 0
DPC count (execution time 500-999 µs): 1
DPC count (execution time 1000-1999 µs): 0
DPC count (execution time 2000-3999 µs): 0
DPC count (execution time >=4000 µs): 0

\


REPORTED ISRs


Highest ISR routine execution time (µs): 190.152695
Driver with highest ISR routine execution time: ataport.SYS - ATAPI Driver Extension, Microsoft Corporation

Highest reported total ISR routine time (%): 0.518007
Driver with highest ISR total time: ohci1394.sys - 1394 OpenHCI Port Driver, Microsoft Corporation

Total time spent in ISRs (%) 0.708194

ISR count (execution time <250 µs): 106636514
ISR count (execution time 250-500 µs): 0
ISR count (execution time 500-999 µs): 0
ISR count (execution time 1000-1999 µs): 0
ISR count (execution time 2000-3999 µs): 0
ISR count (execution time >=4000 µs): 0

\


REPORTED HARD PAGEFAULTS


Process with highest pagefault count: none

Total number of hard pagefaults 5672
Hard pagefault count of hardest hit process: 2230
Highest hard pagefault resolution time (µs): 189424.618263
Total time spent in hard pagefaults (%): 0.032147
Number of processes hit: 0

\


PER CPU DATA


CPU 0 Interrupt cycle time (s): 471.445887
CPU 0 ISR highest execution time (µs): 13.125749
CPU 0 ISR total execution time (s): 19.223901
CPU 0 ISR count: 19895642
CPU 0 DPC highest execution time (µs): 165.077844
CPU 0 DPC total execution time (s): 291.939502
CPU 0 DPC count: 124210992


CPU 1 Interrupt cycle time (s): 367.558870
CPU 1 ISR highest execution time (µs): 190.152695
CPU 1 ISR total execution time (s): 104.112283
CPU 1 ISR count: 9046955
CPU 1 DPC highest execution time (µs): 286.393713
CPU 1 DPC total execution time (s): 226.823998
CPU 1 DPC count: 8492529


CPU 2 Interrupt cycle time (s): 1426.126810
CPU 2 ISR highest execution time (µs): 17.947605
CPU 2 ISR total execution time (s): 336.765682
CPU 2 ISR count: 77686924
CPU 2 DPC highest execution time (µs): 198.534431
CPU 2 DPC total execution time (s): 1159.103831
CPU 2 DPC count: 77807482


CPU 3 Interrupt cycle time (s): 58.773454
CPU 3 ISR highest execution time (µs): 23.016467
CPU 3 ISR total execution time (s): 0.096304
CPU 3 ISR count: 6993
CPU 3 DPC highest execution time (µs): 64.491018
CPU 3 DPC total execution time (s): 21.373416
CPU 3 DPC count: 2054901


Some Imporvement:
After I uninstalled and Installed latest presonus driver, now there’s no drop-outs but just a click/pop now and than, and always click/pop 16-18 seconds after hitting “save” in cubase.

Have you updated your nvidia-drivers? This was once cause for unstable behaviour on my DAW.
Pretty strange, but it sounds like driver related, there are probably some conflicts…

edit:
also check this one too ->
http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-irq-conflict-not-detected-by-windows-but/15014f06-8dc6-41f2-9226-38515db7cfe9

If your CPU cooling is set to active, I read this as CPU throttling - your system is monitoring your CPU temperature and throttling back the frequency when it starts to heat up. Have you tried with this setting turned off?

Steve.

I thought it relates to the CPU fan control?

He’s running a fairly intensive overclock so it could be the CPU overheating and throttling down indeed.

Isn’t Active when fan speed increases in response to increased CPU temperature. Passive setting slows the processor down when the CPU temperature increases. ?

My CPU isn’t overclocked. it’s stock i7-920, with all the CPU “enhancements” in Bios disabled.

OK, I use firewire so let me address the 1394 issue that the LM throws out. Are you using a FW input that is on a card loaded onto a PCI slot, on the MB directly, or via a PCIexpress slot on the MB? For that matter, are you running a Desktop or a Laptop? If you are running a Laptop, I can’t offer much for a fix, sorry. Others here might offer some help.

Anyway, running a Desktop or Laptop, the fact that the LM points out the 1394 connection tells me this is something you need to address. On my system, running the LM, my 1394 port is so far down the readout that I have to really look for it. In my DAW, I run a 1 x Koutech PCI to 1394a Card Model KW-582V2 with good results. I see it is no longer available there (Newegg) but I bought it based on the TI chipset and the positive reviews. It performs better than a TI equipped IOGear PCI card I was using prior, true.

OK, that’s all I got. :cry:


P.S. When you say you are running a ‘stock i7 with no enhancements’, I think you need to get educated about what an 'enhancement actually might mean in this case. It could be that ‘stock’, your OS and BIOS are set up in cruise mode, that your machine is pausing as you record, and then recovering as you place a demand on it. This is not a good thing. You can tune Win7 to perform in ‘high performance’ mode which you should do. I guess I am wondering if you appreciate that recording is a ‘let’s use everything all the time’ kind of drain on the processor. But it’s OK, the processor can deal with it no problem. You can be in ‘high performance’ mode, in other words and not even approach overclocking. You just want to make sure that your computer isn’t resting while you are recording audio with it, that’s the thing.

I don’t know - you’d have to read your motherboard manual. All I’m saying is that to me, Active implies your motherboard is intervening in the cpu heat/frequency/load balance, whereas Passive implies it just keeps the fan going.

As I said, you should try it out. Neither setting will turn your cpu fan off.

I think another poster pointed out that the readout you posted showed your stock cpu speed was 2.67Ghz, whereas it was actually running at close to 3.00Ghz.

Steve.

I’m using a desktop (Asus p6t, Intel i7-920).

Using input on PCI firewire TI-chip based card.

Tried CPU cooling policy Active and Passive, no change.
Deactivated “Steinberg’s Power Scheme” and use High performance mode, no change.
Updated NVidia Drivers, no change.

But When switched to TI compliant 1394 Driver, the LM no longer shows 1394 as highest DPC Latency, but shows some Framework or NTKernel as highest DPC latency. But Audio still clicks and i get “you system seems to have trouble…”

Also I noticed that audio pop occurs at the different instance than “current measured kernel time latency” spike.

By ‘disabled CPU Enhancements’ I mean that CPU settings in BIOS are set according to recommendations from audio websites, (can’t remember which websites).

Tried CPU cooling policy Active and Passive, no change.

Ok, you’ve got a killer machine there it would seem. Have you been to the Native Instruments website to see their configuration notes? They have some good ideas. BTW, have you tried the FireWire card in a different PCI slot? You might want to try that.

I hope you can appreciate that every computer is different. Hm, have you shutdown the MB music player? Do that in the device manager and the bios, this will help if you haven’t done that. The recording interface should be your only music interface. Another consideration would be to disable all the MB FireWire ports if there are any. Device manager for that. That FireWire readout you got seems really odd to me.

Ok, I’ll check back. Don’t worry, you will get this figured out. :sunglasses:

PS - When you are running C6, and open the CPU/HD meter window, when the spike /glitch/pop occurs, which meter lights up indicating overload? Neither? It’s possible you have some HD write issues, maybe a stretch but look anyway.

I read:

Reported CPU speed: 2672.0 MHz
Measured CPU speed: 2989.0 MHz (approx.)

That does sound like an overclock to me :confused:

I have no idea how it got overclocked, if it did :open_mouth:
How do I un-overclock it? if that’s possible

OK, Regarding the over clocking. I have to assume that you removed any of the game type interfaces that come with MBs these days? I had one with my Gigabyte that was a sight to see: at any point of your PC experience you could select it from the task bar and the V8 engine looking icon would appear from which you could select various levels of processor speed. Total BS built for kids playing games.

So, with this removed, it is to the bios for you. My bios and most offered today, have options within that allow you to over clock your processor and your memory. I think once you see what is offered there you will figure out where to set things. In other words, the over clocking features will suggest something heavy duty, beyond ‘normal’. Make your selection and check the box, get out of the bios. If there’s a point to this, a PC like yours should be able to operate at average levels and not fail to get the recording job done. The benefit of setting your processor to run at normal levels is that your machine will run a lot cooler, too. My control room is over the garage and without air conditioning so there are times when it will get 80 degrees in here and I still have to get something done. However hot I might be, the tower and my processor are kept very cool. Well, I have a Coolmaster case and a few fans in it, very quiet, too.

Believe me, you have plenty of firepower there to get the recording job done. And BTW, where I agree that you should not be over locking a recording computer, I also doubt that this is the reason for your audio glitches. As far as I can imagine, this would only happen if your PC was moving from idle to overclock