windows driver for ur22

Hello,
Lately i had to reinstall the yamaha usb driver for my UR22. Since then, when waking up from sleep (S3), i have no sound until i restart winamp.
This was never needed before and in fact i love my UR22/yamaha driver just because this because on previous soundcards there was always trouble with S3.

I reverted to the older driver but unfortunately that had no effect. It seems like something was left behind.

I feel bad because of this. I had it working perfectly. It might not be a great deal to restart winamp on coming out of sleep but it was working before so why is it broken?

Try:
Control Panel -> Power Options -> Change plan settings -> Change advanced power settings ->
USB settings -> USB selective suspend setting
Change this to ‘Disabled’

Also you may try:
Control Panel -> System -> Device Manager -> Universal Serial Bus cintrollers
Open Properties for each item , got to ‘Power Management’ tab and uncheck
‘Allow computer to turn off…’ option

Thank you Yarno.
Your answer reminded me of the days when i was investigating all this sleep/S3 stuff. My settings are as you described, and it was working before, it all started after i tried the latest driver.
Meanwhile i’m prepared to write this off as just some other bug and shrug about it. These things are so complicated with all kinds of different hardware/software combinations one must be careful to not try to win a fight you can’t win. Maybe if i reinstall windows but that’s not gonna happen anytime soon if i can help it.
I made myself a little utility that restarts winamp when the pc comes out of sleep, that will do for now.

Peace and flowers! :slight_smile: