[Windows]USB Midi Device Not Recognized After CB8 Is Running

Has Steinberg answered this yet?

You’re telling me that we have plugins that emulate the sounds of tape heads on tape, but we can’t plug a MIDI device in mid-session? We can connect and jam/record with someone half way across the world with VST. Can’t they figure this out???!?!?! :imp:

This is so embarrassing when I have clients over for sessions. I have to close Cubase, restart, and the whole time listen to them talk about why Protools on a Mac is so much better…

Ridiculous!

FIX THIS STEINBERG!!!

+1

Yes, for christs sake. Get this sorted, this is a highly necessary function and it’s unprofessional of you, Steinberg, not to resolve this issue. It’s been a request for ages, and I might change to another DAW like Reaper instead of buying a new upgrade from you unless this is dealt with in a new update. That’s how important it is to me, and I’m sure, to many others as well.

Really, fix this!

C’mon Mods, please give some indication that this is going to be addressed. It’s called customer support.

+1 for this.
Makes me miss the ease of use of REAPER. I recently moved to Cubase and couldn’t believe I have to restart cubase just to connect a USB device.

+1. This problem is really annoying.

Sometimes I forget the UR 44 interface to connect to the USB port.
On Cubase start, it can not find the interface. I would like a function that the equipment can be re-read.
currently. The only way at the moment is to close and restart Cubase when plugged the interface.

That’s interesting… Meaning you are reporting that you are experiencing this on a Mac. I thought this was related to us running CB and our USB connected stuff on a PC. Maybe you are doing something wrong? Not to highjack this thread maybe you should post your issue again (with more specifics) in the “general” forum section and see if someone can assist.

Good luck. :slight_smile:

Regards :sunglasses:

Edit: Tonylife’s post is gone but his memory and issue live on… :laughing:

Also adding a record of another thread here so that I can keep these requests nice and tidy:
http://www.steinberg.net/forums/viewtopic.php?f=228&t=74134&start=25#p460235

Best of all, this topic again gets to the front page baby. Nice! :wink:

+1

Unbelievable that this still happens. Very annoying.

+1… windows issue or not ,please make some efforts to solve this annoying issue.

+1… yes please!!

Another +1

I would love this, as I forget to turn on my keyboard frequently. :mrgreen:

+1. But it’s been years, and nothing has changed… One of these day, they’re gonna do it and advertise it as a new “feature”… Because, you know, they actually have to do a bit of programming, not like on mac where the os is already doing all the job.

I know people will want to clobber me for saying this, but for those who hate restarting Cubase to plug in a MIDI device, why not use Loopbe MIDI Loopback and MIDI-OX as a go between?

Why, I’ll pulverize ya… Not. :wink:

Steve should never be clobbered for suggesting a workaround. But, I hope Steinberg doesn’t use these suggested workarounds as a reason to not consider this request. That might be “clobber” worthy for them. :cry:

Also apparently there is another program named “rtpMIDI” that can be used as a workaround too.

For me, I hate installing and having extra programs/processes running on my PC. So I never tried any of the suggested workarounds to see if they actually work. Trouping on, I will just continue to restart CB until Steinberg incorporates the feature.

Regards. :sunglasses:

Please make this happen… or at least tell us why it’s not going to happen/ taking so long.

+1

Slight push …

+1

I hope that soon we are going to see some improvement, and maybe with the introduction of the new internal midi system in Windows 10 with the MIDI API.

As said on internet : MIDI API - also available across all Windows 10 devices - this new API allows multi-client access to single MIDI hardware, new jitter-free operation, plus other bug fixes - we hope they embrace the RTP MIDI (over the network too)” .
Actually the common behavior on Windows is that two applications can’t use the same MIDI ports at once, and what’s also common behavior is that a DAW will lock up all of the MIDI ports making it impossible for another application to do anything with MIDI.
If i understand correctly it means that with Windows 10 those problems will be gone, but before software will needs to get updated to support it.

Here the problem is maybe a litlle different because we use only one software, but new MIDI API on Windows 10 will allow us to use few midi applications at the same time, sharing the same midi hardware port number with no conflict or “workaround solution”.
At the end we have new functionalities that should open new “doors” in midi area.

Iam not a specialist at all on programmation, but that new concept in Windows will, i hope, allow new way to conceive midi sharing programmation for Steinberg and so to get rid of those few midi problems.

I couldn’t wait any longer, so I tried something.

I bought a M-Audio MIDISport 1x1 http://www.m-audio.com/products/view/midisport-1x1#.VkShNuKtPhY and connected it to the Yamaha KX8 I use. Now, if I turn on the keyboard and change the output to MIDI from USB after Cubase has started, all is well. Cubase sees the keyboard and I can record etc. I still lose out though, as the transport controls on the KX8 don’t work over MIDI, just USB.